Page 5 of 5 FirstFirst ... 345
Results 41 to 46 of 46

Thread: "Not a recognized Sencha SDK or application folder" on OSX w/2.0.0 Beta 2 / 2.0.1-rc

  1. #41
    Sencha User
    Join Date
    May 2010


    Quote Originally Posted by erpa1119 View Post
    create a file called ".senchasdk" in your sdk folder with the value of "." meaning that this folder is an sdk folder.

    my paths are:
    /Projects/SenchaTouch2/SDK/ -- I put the .senchasdk file in here

    --Hope this helps
    Worked for me in OSX LION. I've been executing from SDK folder not sdktools.. although i got this problem..
    romans-imac-2% sencha generate app GS ../GS

    throw e; // process.nextTick error, or 'error' event on first tick
    Error: Cannot find module '/Users/holms/Development/sencha/touch/command/sencha.js'
    at Function._resolveFilename (module.js:332:11)
    at Function._load (module.js:279:25)
    at Array.0 (module.js:479:10)
    at EventEmitter._tickCallback (node.js:192:40)

  2. #42
    Sencha User
    Join Date
    Mar 2013

    Default The current working directory (D:\Test SenchaSDKTools) is not a recognized Sencha SDK

    Hi All

    I am new to sencha touch development

    Please can any one suggest me detailed steps for how to install and build native application for android using Sencha SDK Tools 2.0.0-beta3 and sencha-touch-2.1.1-gpl.
    I am getting the error like this on my windows machine The current working directory (D:\Test SenchaSDKTools) is not a recognized Sencha SDK or application folder. Running in backwards compatible mode.

  3. #43
    Sencha User
    Join Date
    Mar 2013

    Default Same issue ...

    I'm having same issues with sencha command not recognising the folder as SDK folder

  4. #44
    Sencha User dongryphon's Avatar
    Join Date
    Jul 2009


    If you are using Sencha Touch 2.1 or newer, you need Sencha Cmd v3 (not SDK Tools v2 - those are for Sencha Touch 2.0 only).

    You can get Sencha Cmd v3 at

    The most recent Sencha Cmd v3.1 RC2 can be found at
    Don Griffin

    "Use the source, Luke!"

  5. #45
    Sencha User
    Join Date
    Mar 2013

    Default Please can anyone give me step by step for building native android app using sencha

    I am having SenchaCmd- and sencha-touch-2.1.1-complete-trial packages
    Steps I did is

    sencha touch
    sencha -sdk C:\Users\sudhakar_V03\bin\Sencha\Complete-Trial\\sencha-touch-2.1.1-complete-trial\touch-2.1.1 generate app MyApp D:\senchaTest\SDKApp\MyApp

    I used above command to create the app.
    After that I have added the code to packager file(location D:\senchaTest\SDKApp\MyApp) ;

    Packager file have data of

    { "applicationName":"SenchaTouch2Package",
    "certificateAlias":"androiddebugkey", */
    "orientations": [ "portrait", "landscapeLeft", "landscapeRight", "portraitUpsideDown" ]

    I ran this command on app folder
    sencha app refresh

    I got below Output

    D:\senchaTest\SDKApp\MyApp>sencha app refresh
    Sencha Cmd v3.1.0.239
    [INF] Saving certificate as D:\SenchaCMD3\Sencha\Cmd\repo\pkgs\cert.json
    [INF] Saving private key as D:\SenchaCMD3\Sencha\Cmd\repo\.sencha\repo\private-k
    [ERR] Failed to download remote catalog : Error downloading

    [INF] init-plugin:
    [INF] init-plugin:
    [INF] Invoking plugin (D:\senchaTest\SDKApp\MyApp\.sencha\app\plugin.xml) - supp
    orted targets: -before-app-refresh
    [INF] -before-app-refresh:
    [INF] Invoking plugin (D:\senchaTest\SDKApp\MyApp\.sencha\app\plugin.xml) - supp
    orted targets: app-refresh
    [INF] cmd-root-plugin.init-properties:
    [INF] init-properties:
    [INF] init-sencha-command:
    [INF] init:
    [INF] -before-app-refresh:
    [INF] app-refresh-impl:
    [ERR] This is the default implementation from Sencha CMD and must be overriden b
    y the framework.


    Please let me know other steps and folder structure to build native android using sencha cmd
    Or point me the documents where I can get all the steps and info.

  6. #46
    Sencha User
    Join Date
    Nov 2013


    my SDK is where i extracted my ExtJS files.

    you can generate workspace from within the folder like this:
    sencha generate workspace /tmp/extJSworkSpace
    you can specify it's location if you are not in the folder.
    sencha -sdk ~/current/gaia/static/js/ext-5.1.1 generate workspace /tmp/extJSworkSpace

    contents of the SDK folder looks like:
    ls ~/current/gaia/static/js/ext-5.1.1
    build cmd ext-bootstrap.js LICENSE overrides packages src build.xml examples index.html licenses package.json plugins release-notes.html test welcome

    if you don't specify -sdk flag and are not inside the folder, it will create the workspace still but there will be no 'ext' folder inside (not copied).

    hope this helps.
    Last edited by pyguy; 10 Jun 2015 at 2:06 PM. Reason: bad formatting in quick reply

Page 5 of 5 FirstFirst ... 345

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts