Results 1 to 8 of 8

Thread: Weird characters at the end of AndroidManifest.xml

  1. #1
    Sencha User
    Join Date
    Apr 2012

    Default Weird characters at the end of AndroidManifest.xml


    I have problems with building native app for android. When I run:

    sencha package run configAndroid.json
    I got this error:

    [setup] [Fatal Error] :22:12: Content is not allowed in trailing section.
    I found out that at the end of AndroidManifest.xml are weird characters:

    <?xml version="1.0" encoding="utf-8"?>
    <manifest xmlns:android="" package="eu.mycompany.MobileTest" android:versionCode="1" android:versionName="1.0">
    My OS is Win7 64bit, Sencha SDK 2.0, config file attached.
    Attached Files Attached Files

  2. #2
    Sencha Premium User mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Gainesville, FL


    Odd. I don't see it when I run it.
    Mitchell Simoens @LikelyMitch

    Check out my GitHub:

    Posts are my own, not any current, past or future employer's.

  3. #3


    I'm having the same problem - and my manifest has similar characters - anyone find a fix?

  4. #4


    I have the same problem. I run Windows 7 64-bit. I have tried:
    - Both the commercial and open source SDKs
    - Using both a 32-bit and 64-bit Java JDK
    - Packaging one of the examples (no luck)

    Have anyone found a solution to this problem yet?

  5. #5


    Same problem for me on Windows 7 x64....

  6. #6

    Default Same for me

    using the patched command for android api level. We may just have to forgo android apps or switch to different development.

  7. #7
    Sencha User
    Join Date
    Aug 2012

    Default Same Problem

    Error : "Content not allowed in trailing section "
    while packaging for Debug configuration for Android,
    My OS also Windows 7 ,x64.
    Please do Something I am getting sick of it.

  8. #8
    Sencha User
    Join Date
    Feb 2013

    Default Content not allowed in trailing section

    I had a similar issue this morning. There was a line feed after the </manifest> closing tag. This is a common problem in source files. All I did was remove that trailing line feed and the problem vanished. Perhaps there is a conflict with encoding the text -- be on the lookout for this when you edit files with other editors.

    Parsers ought to, imho...stop parsing after they have found the closing tag...but that is an (OLD!) software engineering issue and not a developer's issue. There is a very easy to apply workaround. The better answer, also imho....would be to find out how this corruption is happening in the first place. Apparently there is some garbage in there when the file gets saved.

    In my case, I believe that my IDE (Eclipse) got forcibly closed overnight...and also, I was using another editor to edit the Sencha Touch files because I have yet to get ADT, PhoneGap and Touch integrated into one project that Eclipse and Ant can build. (I don't think I will, either....) I did not edit the manifest outside of Eclipse, however.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts