Results 1 to 4 of 4

Thread: EditorGridPanel and Column Alignment with Vertical Scrolling...

  1. #1
    Ext User
    Join Date
    Nov 2007
    Location
    Chicago, IL
    Posts
    216

    Default EditorGridPanel and Column Alignment with Vertical Scrolling...

    Hi all-

    I was wondering if any of you have hit this issue...I am using an EditorGridPanel, and when the vertical scrollbar is activated, scrolling works as expected, but the columns (I have 15 columns), towards the end of the grid begin to shift to the left, no longer aligning the column data with the headers of the column. Is there a preference, or something to set, so the columns are aligned to the headers?

    Thanks, and talk soon.
    Chris

  2. #2
    Sencha User jay@moduscreate.com's Avatar
    Join Date
    Mar 2007
    Location
    DC Area =)
    Posts
    16,364

    Default

    chris,

    What browser/operating system?

    sample code (in php or code tags please)?

  3. #3
    Ext User
    Join Date
    Nov 2007
    Location
    Chicago, IL
    Posts
    216

    Default

    Sorry abou that...attached is a screen shot of what I see. It occurs on firefox and IE alike, and some code used to do the render is below. I set, in the column model, all columns to have a width of 200.

    Code:
     
    grid =new Ext.grid.EditorGridPanel
     
     
    store:this.getDataStore(),
    cm:this.getColumnModel(),
    tbar:this.getGridToolbar(),
    renderTo:'workingGrid',
    shim:false,
    animCollapse:false,
    constrainHeader:true,
    frame:false,
    plugins: deleteCheckbox,
    autoScroll:true,
    clicksToEdit:1,
    disableSelection:true,
    trackMouseOver:true,
    stripeRows:true,
    autoFill:true,
    id:'dynamicGrid',
    iconCls:'icon-grid',
    width:1275,
    height:280,
    frame:true
     
    
    });
    Attached Images Attached Images

  4. #4
    Ext User
    Join Date
    Nov 2007
    Location
    Chicago, IL
    Posts
    216

    Default

    Some additional observations I just noticed on this...

    It seems that when I set the viewConfig option to forceFit:true, it adds another blank column to the end of the grid...when scrolling is needed, the bar is placed in the blank column.

    I hit the above issue when I do not use the foreFit option (and I don't want to use it, since I need to specify my column widths initially).

    Any ideas how to get this blank scroll column to appear?

    Thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •