Results 1 to 3 of 3

Thread: Removing number formatting from numberfield

  1. #1

    Question Removing number formatting from numberfield


    I want to place a textfield for the user to capture his phone number. As I want a numeric keypad to appear, I was looking to implement a numberfield.

    The first problem is that maxLength doesn't work, so I implemented a listener to overcome that.

    However my issue now is that on Safari Browser the numberfield formats automatically the resulting value with thousands separator.

    I guess that this behavior is because of the browser implementation of number imput, but is there any way to disable this formatting from sencha configurations?

    Thanks in advance.

  2. #2
    Sencha Premium User mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Gainesville, FL


    If you want special formatting then you could go with a textfield and prevent keys to be typed in a keydown listener stopping the event.
    Mitchell Simoens @LikelyMitch

    Check out my GitHub:

    Posts are my own, not any current, past or future employer's.

  3. #3


    Hi mitchel,

    Thanks, the problem is that the formatting occurs when the textfield loses focus or when I use setValue().

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts