Results 1 to 4 of 4

Thread: [4.1.0 Beta and 4.0.7] Can't highlight row

    Looks like we can't reproduce the issue or there's a problem in the test case provided.
  1. #1
    Sencha Premium User
    Join Date
    Feb 2010
    Location
    Pennsylvania
    Posts
    576

    Default [4.1.0 Beta and 4.0.7] Can't highlight row

    REQUIRED INFORMATION Ext version tested:
    • Ext 4.1 rev 0 Beta 1


    • Ext 4.0 rev 7

    Browser versions tested against:
    [LIST]/LIST]DOCTYPE tested against:
    • None

    Description:
    • Row will not highlight


    Steps to reproduce the problem:
    • var rec = grid.store.getAt( 0 );
    • Ext.fly( grid.getView().getNode( rec ) ).highlight()

    The result that was expected:
    • Row highlights

    The result that occurs instead:
    • Nothing happens

    Test Case:
    Code:
         <html>
    <head>
            <script type="text/javascript" src="ext-4.1.0-beta-1/ext-all-debug.js"></script>
            <link type="text/css" rel="stylesheet" href="ext-4.1.0-beta-1/resources/css/ext-all.css" />
            
            
            <script>
    Ext.onReady(function () {
            Ext.create( 'Ext.container.Viewport', {
                    layout: 'fit',
                    items: [
                            {
                                    xtype: 'grid',
                                    title: 'test',
                                    store: Ext.create( 'Ext.data.Store', {
                                            fields: [
                                                    'asd'
                                            ],
                                            data: [
                                                    {
                                                            asd: 'shjfghjsn'
                                                    }
                                            ]
                                    } ),
                                    columns: [
                                            {
                                                    dataIndex: 'asd'
                                            }
                                    ]
                            }
                    ]
            } );
    } );    
    
    
    
    
            </script>
    </head>
    <body>
    </body>
    </html>
    HELPFUL INFORMATION Debugging already done:
    • none

    Possible fix:
    • not provided

    Additional CSS used:
    • only default ext-all.css

    Operating System:
    • Linux - Ubuntu

  2. #2
    Sencha Premium User mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    40,379

    Default

    The issue is you can't do a background-color on a <tr> element... on the <td> it works.
    Mitchell Simoens @LikelyMitch

    Check out my GitHub:
    https://github.com/mitchellsimoens

    Posts are my own, not any current, past or future employer's.

  3. #3
    Sencha Premium User
    Join Date
    Apr 2007
    Location
    Sydney, Australia
    Posts
    19,258

    Default

    This isn't a bug. The td has a background colour set, so setting the background on the tr is going to have no effect. You can either:
    a) Set the background colour on the cell to be transparent via the css/scss
    b) Select all the direct child tds on from the row itself and highlight them

  4. #4
    Sencha Premium User
    Join Date
    Feb 2010
    Location
    Pennsylvania
    Posts
    576

    Default

    ............................................________
    ....................................,.-'"...................``~.,
    .............................,.-"..................................."-.,
    .........................,/...............................................":,
    .....................,?......................................................\,
    .................../...........................................................,}
    ................./......................................................,:`^`..}
    .............../...................................................,:"........./
    ..............?.....__.........................................:`.........../
    ............./__.(....."~-,_..............................,:`........../
    .........../(_...."~,_........"~,_....................,:`........_/
    ..........{.._$;_......"=,_......."-,_.......,.-~-,},.~";/....}
    ...........((.....*~_......."=-._......";,,./`..../"............../
    ...,,,___.\`~,......"~.,....................`.....}............../
    ............(....`=-,,.......`........................(......;_,,-"
    ............/.`~,......`-...............................\....../\
    .............\`~.*-,.....................................|,./.....\,__
    ,,_..........}.>-._\...................................|..............`=~-,
    .....`=~-,_\_......`\,.................................\
    ...................`=~-,,.\,...............................\
    ................................`:,,...........................`\..............__
    .....................................`=-,...................,%`>--==``
    ........................................_\..........._,-%.......`\
    ...................................,<`.._|_,-&``................`


    Thanks guys. I apologize. I should have looked to see if there was a background on a child element. It worked for a tr on 4.0.2a so I didn't investigate.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •