Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Theming issue: Line 15: Functions may only be defined...

  1. #1
    Sencha User
    Join Date
    Mar 2009
    Location
    Boise, ID
    Posts
    6,165
    Answers
    505

    Default Answered: Theming issue: Line 15: Functions may only be defined...

    In following the guide for Theming I compile and get the following error:
    Line 115: Functions may only be defined at the root directory of a document.

    Has anyone else followed the theming guide and had success? Maybe my folder setup is wrong?

  2. Seems like an issue with SASS rolling back to an older version seems to resolve the issue:

    gem uninstall sass
    gem install sass -v 3.1.1

    Found on stack overflow:
    http://stackoverflow.com/questions/7...-to-sass-3-1-8

  3. #2
    Sencha User
    Join Date
    Aug 2011
    Posts
    2
    Answers
    1

    Default Having same issue

    Having same issue anyone resolved this?

    From my-ext-theme.css:
    Syntax error: Functions may only be defined at the root of a document.
    on line 115 of C:/www/clientpos/extjs/resources/themes/stylesheets//ext4/default/mixins/_frame.scss
    from line 4 of C:/www/clientpos/extjs/resources/themes/stylesheets//ext4/default/_mixins.scss
    from line 9 of C:/www/clientpos/extjs/resources/themes/stylesheets//ext4/default/_all.scss
    from line 8 of C:/www/clientpos/resources/sass/my-ext-theme.scss

  4. #3
    Sencha User
    Join Date
    Aug 2011
    Posts
    2
    Answers
    1

    Default

    Seems like an issue with SASS rolling back to an older version seems to resolve the issue:

    gem uninstall sass
    gem install sass -v 3.1.1

    Found on stack overflow:
    http://stackoverflow.com/questions/7...-to-sass-3-1-8

  5. #4
    Ext JS Premium Member
    Join Date
    Apr 2008
    Location
    Oslo
    Posts
    64
    Answers
    2

    Smile

    I have the same issue with sass 3.1.8
    Rolled back to sass 3.1.1 resolve the issue.

    slemmon and eddiegarza,
    Thank you for reporting!

  6. #5
    Sencha User
    Join Date
    Mar 2009
    Location
    Boise, ID
    Posts
    6,165
    Answers
    505

    Default

    @eddiegarcia
    Thx for the fix instructions.

    Has anyone filled out a bug report on this officially that you all are aware of? Wonder if this could all be remedied in 4.1.

  7. #6
    Sencha User
    Join Date
    Jan 2011
    Location
    San Juan, PR
    Posts
    84

    Default

    same here... Thanks for the info "gem install sass -v 3.1.1" did the trick

  8. #7
    Ext JS Premium Member
    Join Date
    Jul 2007
    Posts
    219

    Default

    Waiting for Sencha guys to fix this in their code

  9. #8
    Sencha User
    Join Date
    Aug 2011
    Location
    Franklin, TN
    Posts
    16

    Default

    this is really frustrating, i'd love to know a timetable of when i can use the latest version of compass and not have to use an old version

  10. #9
    Sencha User
    Join Date
    Aug 2011
    Location
    Franklin, TN
    Posts
    16

    Default

    this is really frustrating, i'd love to know a timetable of when i can use the latest version of compass and not have to use an old version

  11. #10
    Ext JS Premium Member
    Join Date
    May 2007
    Location
    Reading, MA
    Posts
    7

    Default

    Just encountered this today. The only silver lining is this forum thread is the first result in google.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •