Results 1 to 5 of 5

Thread: Max size of json ?

  1. #1
    Sencha User tdikarim's Avatar
    Join Date
    Jun 2007
    Location
    Belgium - Brussel
    Posts
    142

    Default Max size of json ?

    Hi all,

    Ext-1.1
    FF : ok
    IE7 : not ok

    I have a JsonString that i passed to the server. All is ok if I don't send all the row of my grid
    I have the problem only with IE7. In FF it's ok
    for example :
    This wil passed
    --------------
    [{"ZT2_MATNR":"1000","ZT2_CNK":"100000","ZT2_FARMIX":"6000","ZT2_ORGASSUR":"3","ZT2_DATBI":"2003-10-31T00:00:00","ZT2_DATAB":"1999-05-01T00:00:00","ZT2_NUMORDRE":1,"ZT2_NCONDITION":1,"ZT2_REMBOURS":"SB","ZT2_CRITMAL":"","ZT2_AUTORIS":"","ZT2_DATENCODAGE":"1999-05-01T00:00:00","RN":2,"ARTICLE_LIBELLE":"XXXXXXXXX XXX. X X X XX X XX XXX. + ","ZCO_PRIX_PUBLIQUE":"0,35","ZCO_BASE_REMBOURSEMENT":"","ZT2S_ATC":"","ZT2S_ATC4":"-1","ZT2S_GM":"","ZT2S_GR":"","INAMI_Q":"1","INAMI_Ob":" ","INAMI_CatRemb":"SB","INAMI_Crit":"","INAMI_Autorisation":"","INAMI_CHAPITRE":"","INAMI_PARAGRAPHE":""},{"ZT2_MATNR":"2000","ZT2_CNK":"16200","ZT2_FARMIX":"326","ZT2_ORGASSUR":"3","ZT2_DATBI":"9999-12-31T00:00:00","ZT2_DATAB":"1999-05-01T00:00:00","ZT2_NUMORDRE":1,"ZT2_NCONDITION":1,"ZT2_REMBOURS":"SB","ZT2_CRITMAL":"","ZT2_AUTORIS":"","ZT2_DATENCODAGE":"1999-05-01T00:00:00","RN":9,"ARTICLE_LIBELLE":"XXXXXXXXXX XXXX. XX X X XX ","ZCO_PRIX_PUBLIQUE":"0,43","ZCO_BASE_REMBOURSEMENT":"0,43","ZT2S_ATC":"","ZT2S_ATC4":"-1","ZT2S_GM":"","ZT2S_GR":"","INAMI_Q":"1","INAMI_Ob":" ","INAMI_CatRemb":"SB","INAMI_Crit":"","INAMI_Autorisation":"","INAMI_CHAPITRE":"1","INAMI_PARAGRAPHE":""}]


    This wil not passed (I have add one parameter : ONIG_Q) :
    --------------------------------------------------------
    [{"ZT2_MATNR":"1200","ZT2_CNK":"100000","ZT2_FARMIX":"6000","ZT2_ORGASSUR":"3","ZT2_DATBI":"2003-10-31T00:00:00","ZT2_DATAB":"1999-05-01T00:00:00","ZT2_NUMORDRE":1,"ZT2_NCONDITION":1,"ZT2_REMBOURS":"SB","ZT2_CRITMAL":"","ZT2_AUTORIS":"","ZT2_DATENCODAGE":"1999-05-01T00:00:00","RN":2,"ARTICLE_LIBELLE":"XXXXXXXXX XXX. X X X XX X XX XXX. + ","ZCO_PRIX_PUBLIQUE":"0,65","ZCO_BASE_REMBOURSEMENT":"","ZT2S_ATC":"","ZT2S_ATC4":"-1","ZT2S_GM":"","ZT2S_GR":"","INAMI_Q":"1","INAMI_Ob":" ","INAMI_CatRemb":"SB","INAMI_Crit":"","INAMI_Autorisation":"","INAMI_CHAPITRE":"","INAMI_PARAGRAPHE":"","ONIG_Q":"1"},{"ZT2_MATNR":"2000","ZT2_CNK":"16000","ZT2_FARMIX":"326","ZT2_ORGASSUR":"3","ZT2_DATBI":"9999-12-31T00:00:00","ZT2_DATAB":"1999-05-01T00:00:00","ZT2_NUMORDRE":1,"ZT2_NCONDITION":1,"ZT2_REMBOURS":"SB","ZT2_CRITMAL":"","ZT2_AUTORIS":"","ZT2_DATENCODAGE":"1999-05-01T00:00:00","RN":9,"ARTICLE_LIBELLE":"XXXXXXXXXX XXXX. XX X X XX ","ZCO_PRIX_PUBLIQUE":"7,43","ZCO_BASE_REMBOURSEMENT":"7,43","ZT2S_ATC":"","ZT2S_ATC4":"-1","ZT2S_GM":"","ZT2S_GR":"","INAMI_Q":"1","INAMI_Ob":" ","INAMI_CatRemb":"SB","INAMI_Crit":"","INAMI_Autorisation":"","INAMI_CHAPITRE":"1","INAMI_PARAGRAPHE":"","ONIG_Q":"1"}]

    Thanks for your help

  2. #2
    Sencha User tdikarim's Avatar
    Join Date
    Jun 2007
    Location
    Belgium - Brussel
    Posts
    142

    Thumbs up Parametre GET limit

    Hi,

    It is a problem involved in the parameter GET which under IE7 with a size limits 4ko.
    Code:
    ds_Simulation = new Ext.data.Store({
    	proxy: new Ext.data.ScriptTagProxy({
    		,	url: 'http://logistic/ZTARIF/ConnectionZtarif2/data.php'
    		,	timeout : 60000
    }),
    I try to force POST method but not work
    Code:
    ds_Simulation = new Ext.data.Store({
    	proxy: new Ext.data.ScriptTagProxy({
                                          method : 'post'
    		,	url: 'http://logistic/ZTARIF/ConnectionZtarif2/data.php'
    		,	timeout : 60000
    }),
    How then I to increase this size or last by the method post ?

    Have you an idea

  3. #3
    Sencha User tdikarim's Avatar
    Join Date
    Jun 2007
    Location
    Belgium - Brussel
    Posts
    142

    Default method Post with SriptTagProxy

    Hi

    I advance in my problem ...

    Someone know how to use SriptTagProxy with the method POST.
    Because the method GET have a size limit in IE7.

    ANY suggestions ...

    Thanks for your help

  4. #4
    Sencha User tdikarim's Avatar
    Join Date
    Jun 2007
    Location
    Belgium - Brussel
    Posts
    142

    Default Post method and SriptTagProxy

    Ok,

    I replace SriptTagProxy by HttpProxy call and now it's work...
    Code:
    ds_Simulation = new Ext.data.Store({
            proxy: new Ext.data.ScriptTagProxy({
    	             method: 'post'
    	,	url: 'http://logistic/ZTARIF/ConnectionZtarif2/data.php'
    	,	timeout : 60000
    }),
    NOW:
    Code:
    ds_Simulation = new Ext.data.Store({
            proxy: new Ext.data.HttpProxy({
            		method: 'post'
    	,	url: 'http://logistic/ZTARIF/ConnectionZtarif2/data.php'
    	,	timeout : 60000
    }),

    Question for advanced Ext user ??
    How can i use scriptTagProxy with method Post if my php is an another domain with a big parameter ?

  5. #5
    Sencha User Monty Spears's Avatar
    Join Date
    Mar 2011
    Location
    8220 N Perkins Rd, Stillwater, OK 74075
    Posts
    1

    Default

    Quote Originally Posted by tdikarim View Post
    Hi,

    It is a problem involved in the parameter GET which under IE7 with a size limits 4ko.
    Code:
    ds_Simulation = new Ext.data.Store({
    	proxy: new Ext.data.ScriptTagProxy({
    		,	url: 'http://logistic/ZTARIF/ConnectionZtarif2/data.php'
    		,	timeout : 60000
    }),
    I try to force POST method but not work
    Code:
    ds_Simulation = new Ext.data.Store({
    	proxy: new Ext.data.ScriptTagProxy({
                                          method : 'post'
    		,	url: 'http://logistic/ZTARIF/ConnectionZtarif2/data.php'
    		,	timeout : 60000
    }),
    How then I to increase this size or last by the method post ?

    Have you an idea
    Thanks for sharing it. According to me the problem in GET parameter. If it can analyze properly then it get solved. keep updating.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •