Page 52 of 53 FirstFirst ... 24250515253 LastLast
Results 511 to 520 of 525

Thread: API Documentation Content Bugs

    Thank you for reporting this bug. We will make it our priority to review this report.
  1. #511
    Sencha User
    Join Date
    Feb 2014
    Posts
    8

    Default

    ComboBox#tpl[1] should inherit its documentation from BoundList#tpl[2].

    The ComboBox#itemSelector[3] from Ext JS 3.4.0 has no documentation for Ext JS 4.0.0 and greater.
    If it was removed it should be marked that way.

    An example for a custom class for the items of a BoundList is missing. Like:
    Code:
    Ext.create('Ext.form.field.ComboBox', {
        fieldLabel: 'State',
        queryMode: 'local',
        displayField: 'name',
        valueField: 'abbr',
        store: Ext.create('Ext.data.Store', {
            fields: ['abbr', 'name'],
            data: [
                {"abbr":"AL", "name":"Alabama"},
                {"abbr":"AK", "name":"Alaska"},
                {"abbr":"AZ", "name":"Arizona"}
                //...
            ]
        }),
        listConfig: {
            itemCls: 'custom',
            tpl : '<tpl for="."><div class="custom">{name}</div></tpl>'
        }
    });
    [1]: http://docs-origin.sencha.com/extjs/...mboBox-cfg-tpl
    [2]: http://docs-origin.sencha.com/extjs/...ndList-cfg-tpl
    [3]: http://docs-origin.sencha.com/extjs/...g-itemSelector

  2. #512
    Sencha User
    Join Date
    May 2009
    Posts
    158

    Default

    Ext.data.Model.hasOne creates a hasOne assocition, but it is undocumented.Should it be documented?See http://www.sencha.com/forum/showthre...a.Model.hasOne

  3. #513
    Sencha Premium User
    Join Date
    Nov 2010
    Location
    Chicago
    Posts
    2,339

    Default Method Stateful. getStateId should not be private

    The getStateId method should probably be public or protected.
    Code:
    Ext.define('Ext.state.Stateful', {
        ....
        /**
         * Gets the state id for this object.
         * @return {String} The 'stateId' or the implicit 'id' specified by component configuration.
         * @private
         */
        getStateId: function() {
            var me = this;
            return me.stateId || (me.autoGenId ? null : me.id);
        },
        ...

  4. #514
    Sencha Premium User mankz's Avatar
    Join Date
    Nov 2007
    Location
    Stockholm, Sweden
    Posts
    3,153

    Default

    Code:
    if (me.fireEvent('beforerefresh', me) !== false) {
    Ext.view.View should mention the possibility of blocking the refresh by returning false - currently this is not mentioned in the docs

  5. #515
    Ext JS Premium Member
    Join Date
    Dec 2011
    Posts
    23

    Default Inconsistent event name in Ext.dd.DragTracker

    In Ext.dd.DragTracker, API doc event name is different from source code event name (beforestart vs beforedragstart):

    Code:
                /**
                 * @event beforestart
                 * @param {Object} this
                 * @param {Object} e event object
                 */
                'beforedragstart',

  6. #516
    Sencha User olecom's Avatar
    Join Date
    Oct 2011
    Location
    Republic of Belarus
    Posts
    50

    Default Ext.DomHelper docs

    Code:
    var tpl = new Ext.DomHelper.createTemplate(html);
    these example lines must be without `new`.

  7. #517
    Sencha Premium Member
    Join Date
    Aug 2008
    Posts
    8

    Default Ruby Installation instructions missing important info!

    Hi,
    When following the guide for theming, which refers to the sencha CMD tutorial, neither states that (on windows at least) you need Ruby <2.0 So, the natural thing to do (which I have just done) is install the latest Ruby, try to compile, and poof! Only then does an error message pop up saying the wrong version of Ruby is installed, and I need to go back, uninstall ruby, re-install the old version, re-set up/change the path variables... a lot of trouble due to a lack of important documentation.

    This is the sort of thing that will frustrate new users (though I've been with Sencha for 8 years), and is a very simple thing to put on a "how to install page" http://docs.sencha.com/extjs/4.2.2/#/guide/command
    Thanks.

  8. #518
    Sencha User slemmon's Avatar
    Join Date
    Mar 2009
    Location
    Boise, ID
    Posts
    6,165

    Default

    Ruby <2 was required for past versions of Cmd, but works with the current stable Cmd. You may need to run "sencha upgrade" to ensure you have the latest version of Cmd. You will then run "sencha app upgrade" for each app / application within a workspace to upgrade the application to work with the current release of Cmd.

  9. #519
    Sencha Premium User mankz's Avatar
    Join Date
    Nov 2007
    Location
    Stockholm, Sweden
    Posts
    3,153

    Default

    'onRender' template method is missing in the Ext.Panel docs.

  10. #520
    Sencha User
    Join Date
    Jan 2012
    Location
    Kansas
    Posts
    11

    Default

    The url property of a button is undocumented but appears to be an alias of the href property.

Page 52 of 53 FirstFirst ... 24250515253 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •