Results 1 to 4 of 4

Thread: LoadRecord not working !!Weird!!

  1. #1
    Sencha User
    Join Date
    Jul 2008
    Location
    Brooklyn NY
    Posts
    120

    Default LoadRecord not working !!Weird!!

    this line is panel.getForm().loadRecord(payer) working on my dev environment but when I post the update to the server, the form doesn't get populated. I have identical files as I do in my computer. Same Ext version, same code same everything and no errors. It executes just fine but it is not showing on the server and it's showing on mine.

    Any Ideas?

  2. #2
    Sencha User
    Join Date
    Jul 2008
    Location
    Brooklyn NY
    Posts
    120

    Default

    BEFORE: Not working
    panel.getForm().loadRecord(payer);
    panel.addButton({text: 'OK',...
    panel.addButton({text: 'Cancel',...
    window.show();

    AFTER: Working
    panel.addButton({text: 'OK',...
    panel.addButton({text: 'Cancel',...
    window.show();
    panel.getForm().loadRecord(payer);

    I have no idea why it's doing that but I am glad it works.

  3. #3
    Sencha User Condor's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    24,245

    Default

    A form must be rendered before you can set the values/load a record.

  4. #4
    Sencha User
    Join Date
    Jul 2008
    Location
    Brooklyn NY
    Posts
    120

    Default

    Thanks Condor but I couldn't explain why it was working ok on my computer and not on the server with the same exact code.

Similar Threads

  1. loadRecord on form
    By paubach in forum Ext 3.x: Help & Discussion
    Replies: 1
    Last Post: 21 May 2010, 1:07 PM
  2. loadRecord Help
    By Bucs in forum Ext 2.x: Help & Discussion
    Replies: 2
    Last Post: 28 Sep 2009, 7:24 AM
  3. loadRecord without id
    By Radziu in forum Ext 2.x: Help & Discussion
    Replies: 2
    Last Post: 20 Mar 2009, 6:24 PM
  4. [2.2] BasicForm loadRecord
    By eserikto in forum Ext 2.x: Help & Discussion
    Replies: 2
    Last Post: 28 Oct 2008, 4:23 AM
  5. How exactly loadRecord() works?
    By SyRenity in forum Ext 2.x: Help & Discussion
    Replies: 11
    Last Post: 30 May 2008, 12:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •