View Full Version : [CLOSED][3.2 SVN] Tree Redorder Bug

Lloyd K
12 Mar 2010, 4:09 AM
This was supposed to have been fixed, however in the SVN checkout of 3.2 this does not appear to be the case, check out this screencast showing what's going on:


Jamie Avins
12 Mar 2010, 9:09 AM
It seems fine at: http://www.extjs.com/deploy/ext-3.2-beta/examples/tree/reorder.html

Can you verify?

Lloyd K
15 Mar 2010, 6:07 AM
OK I've figured out what's wrong, kind of. If I switch to the beta release it works fine, however the SVN checkout does not work. According to TortoiseSVN I'm at revision 6298 however the last log entry I can get up is infact 6246 on the 6th of March and with this build the tree acts the way it does in the video.

Are GIT and SVN properly sync'd?

Jamie Avins
15 Mar 2010, 9:06 AM
SVN is correct, have you tried to wipe it out and check it back out?

Lloyd K
15 Mar 2010, 9:08 AM
Of course, that's one of the first things I did :/

Lloyd K
15 Mar 2010, 9:48 AM
OK I did a clean checkout and build and put it on one of my websites and the problem still exists, check out:


Directory browsing is on for http://www.lloydkinsella.net/treetest/ if you want to poke around the build.

Jamie Avins
15 Mar 2010, 10:01 AM
Not sure what to tell you, check your building process maybe?

Lloyd K
16 Mar 2010, 5:37 AM
Hi Jamie,

Just to make sure when I got home from work I did a checkout from there, I then built it and uploaded it to the same place and the tree STILL freaks out. I cannot see how this is me given two widely separate places and the build process I've done a thousand times.

This is the build line I used:

java -jar "C:\Users\Lloyd\Desktop\Tree Check\JSBuilder2\JSBuilder2.jar" --projectFile "C:\Users\Lloyd\Desktop\Tree Check\checkout\ext.jsb2" --homeDir "C:\Users\Lloyd\Desktop\Tree Check"

Jamie Avins
16 Mar 2010, 8:55 AM
I assume youre pulling from the branches/3.2.x, if you use verbose on the build, any warnings or anything? The sample works fine against the latest svn as well as the beta build.

Lloyd K
16 Mar 2010, 9:24 AM
Ahh now I'm pulling from trunk and not branch, perhaps that's where it's going wrong.

Lloyd K
16 Mar 2010, 9:34 AM
Yep branch works fine. Glad I finally solved that one I thought I was going mad. Thanks for your patience and input.

Jamie Avins
16 Mar 2010, 10:08 AM
Glad to hear it was resolved. These can drive you crazy.