View Full Version : [SOLVED]Included file in Viewport Not Working Properly

24 Feb 2010, 10:02 AM
Ok, i made some progress now my grid is displaying in FF and Chrome.
But there is another problem: first im getting a strange message in FireBug after clicking "Ksi?ga Inwentarzowa" in my tree panel it's:

b[d.xtype || e] is not a constructor

but grid is displaying correctly.

Second problem is stranger it's say's

assetsWindow is undefined

after clicking "Dodaj" [add].
how come? i have defined my window in my file. It's might be a problem of scope, but dunno.

http://images43.fotosik.pl/264/1c4c6beb15935fe5m.png (http://www.fotosik.pl/showFullSize.php?id=1c4c6beb15935fe5)

Here is my file with is included to my layout:

on bottom section is define of my Window - assetsWindow,
please see also handler that trigger action assetsWindow.open() in GridPanel it's also might be a problem.

The best part is if the file will run separately everything works fine.

FIRST PROBLEM SOLVED had xtype: 'spinner' but dont have included ux scripts :)

SECOND PROBLEM SOLVED dunno how , i just restore last back-up of my app.

I highly recommended that you make regular back-up copies, can sometimes be really useful :)

Regards Czapla

25 Feb 2010, 3:30 AM

26 Feb 2010, 3:31 AM