View Full Version : [3.1.0] Has anyone got Locking Grid Header and Grouping Header working?

15 Jan 2010, 6:43 AM

I'm fairly new to ext.js but I've tried scanning the docs and forums for an answer to this. I'm trying to creat a table which has a left hand locking grid column header (as shown in this example http://www.extjs.com/deploy/dev/examples/grid/locking-grid.html) and then has a set of grouped columns (as shown in this example http://www.extjs.com/deploy/dev/examples/grid/ColumnHeaderGroup.html (http://www.extjs.com/deploy/dev/examples/grid/locking-grid.html)). I was wondering if anyone has an example of this working already with ext.js 3.1.0 as I'm struggling to workaround the errors that come up. The main error I get at the moment is: line 693 in (LockingGridView.js (http://www.extjs.com/deploy/dev/examples/ux/LockingGridView.js)):

this.innerHd.firstChild.firstChild.style is undefined

I understand why this error crops up but before I go digging deeper I was wondering if anyone else has done this with 3.1.0 already. My code at the moment is a modified version of the grid column header grouping example which I've attached to this post.


15 Jan 2010, 6:49 AM
This requires a bit more work than you think!

ps. I created a LockingColumnHeaderGroup for other customers which you can buy for 150.

15 Jan 2010, 6:57 AM
I guess that answer I was expecting :) We recently purchased the licence for your extra so we do have that available but given these new examples in 3.1.0 I wondered whether it was easier to do now. I see the answer is no.

Thanks for the reply.

15 Jan 2010, 8:41 AM
I'd be interested in learning more about your Ext components you have for sale. Is there a web site?

9 Feb 2010, 2:25 AM
I am interested to use your extension LockingColumnHeaderGroup, i need more infomations for the price and the use in my products. I would like to know how i can pay you and if you are able to bill your work.


5 May 2010, 7:57 AM
I understand why this error crops up

I am getting the same error. I do not get the reason why I am getting this error. Can you please share why this error comes up?