View Full Version : Combobox Problem

14 Oct 2009, 3:54 AM

I'm trying to achive the following without success:

A combo box with two selectable values 'abc' and 'def'.
It should not be possible to type any text into the input field.

Sounds quite easy but all I tried wasn't successful.
After I selected one of the two available values via dropdown it is no longer possible to select anything different as only this value is shown in the dropdown list and nothing else.

I played around with all the different config options but nothing seems to work.

Thanks a lot for your help.


14 Oct 2009, 4:28 AM
add the following:

editable : false,
triggerAction : 'all'

14 Oct 2009, 5:28 AM
add the following:

triggerAction : 'all'

That did the trick.
I really tried a lot but while reading throu the API docs I did not see any relation of this option to the problem I had. I think it's getting clearer now.

Thanks a lot.

14 Oct 2009, 5:31 AM
editable, to me makes sense. triggerAction doesn't make sense if you don't know that the arrow is a 'trigger'.