View Full Version : Ext won't run upon install

30 Apr 2009, 5:34 PM
Help please,

I downloaded and extracted Ext 2 and tried to run the index.html under docs. I get the following error.

HTTP Error 500.0 - Internal Server Error

Calling LoadLibraryEx on ISAPI filter "C:\Windows\Microsoft.NET\Framework\v2.0.50727\\aspnet_filter.dll" failed

The file is in that location (Except for the double backslashes). I am on PC with Vista, IIS, IE, Chrome or FireFox all the same.
Any ideas what may be wrong?

30 Apr 2009, 6:51 PM
its not ext problem. there is a problem in your server. check it

30 Apr 2009, 7:10 PM
You are absolutely correct. I found this post on http://forums.iis.net/t/1150633.aspx
I had exactly the same problem as this and found that it was caused by some kind of installation adding an extra line to my iis applicationHosts.config file.
The offending line was in the file C:\Windows\System32\inetsrv\config\applicationHost.config. The "isapiFilters" section should look like:
EDIT: Gah, the XML's close enough.
<clear />
<filter name="ASP.Net_2.0.50727.0" path="%windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_filter.dll" enabled="true" enableCache="true" preCondition="bitness32" />
<filter name="ASP.Net_2.0.50727-64" path="%windir%\Microsoft.NET\Framework64\v2.0.50727\aspnet_filter.dll" enabled="true" enableCache="true" preCondition="bitness64" />
My problem was that an extra line had been added before the first two, directly referencing the aspnet_filter.dll with a fixed path, the double-backslash you see in the error, but crucially without the "bitness" precondition, meaning that both 32 and 64 bit components were being run against the 32 bit aspnet_filter.dll.
I deleted the offending line, and all has started working again.
You may find that the command you tried above has changed one of your application pools to 32 bit from 64 bit. You may need to change it back if it wasn't actually the problem.

I removed the extra line and rebooted, problem solved. Thank you.
The only thing I have installed lately is Kaspersky Internet Security. Maybe it added it.