View Full Version : [CLOSED][3.0] Proxy load method not recieving arguments

23 Apr 2009, 7:19 AM
Before udpating from SVN a few minutes ago, the following method signature in my custom DWR data proxy worked:

load : function(inParams, inReader, inCallback, inScope, inArgs) {

After this update though, inArgs is coming up as undefined. I don't know if this is a bug or just an expected signature change or something... looking through the DataProxy.js code, it seems like it should still work... I do know that load is deprecated, so I'm wondering if someone updated something and didn't also update it to allow load to work as well?

23 Apr 2009, 7:33 AM
Looking like this might be my own stupidity (I know, not exactly shocking!)... I'll post back and close the thread when I confirm that's the case, in the mean time, ignore this post...

23 Apr 2009, 7:40 AM
Yes indeed, was me being dumb... the doRequest method signature changed, but I didn't update the overridden version in my proxy code to match. Once I did that, problem solved. Sorry 'bout that.