PDA

View Full Version : Install Themer 1.3.9 on Ubuntu 20.04LTS



russ396
20 Nov 2020, 10:11 AM
These are the steps I did to get Sencha Themer 1.3.9 installed on Ubuntu 20.04LTS:

1) Download Themer
2) unzip Themer
3) sudo ./SenchaThemer*sh
4) Install for everyone and install to default location of /opt/Sencha/Themer
5) sudo apt install libcanberra-gtk-module libgconf-2-4
6) Based on https://unix.stackexchange.com/questions/589993/pango-error-harfbuzz-version-too-old,
download the following 3 .deb files manually (choose your architecture and download the .deb):



libpango-1.0-0 (1.42.4-7) (https://packages.ubuntu.com/bionic/libs/libpango-1.0-0)
libpangocairo-1.0-0 (1.42.4-7) (https://packages.ubuntu.com/bionic/libpangocairo-1.0-0)
libpangoft2-1.0-0 (1.42.4-7) (https://packages.ubuntu.com/bionic/libpangoft2-1.0-0)

Open the .deb with Archive Manager, and open data.tar.xz file, then go to /./usr/lib/x86_64-linux-gnu/ and extract those two files in the /opt/Sencha/Themer folder. Repeat for each downloaded .deb file. I had to make a temp folder to extract and then sudo copy files to /opt/Sencha/Themer as it is owned by root. This is basically getting the pango file from Ubuntu 18.04LTS and placing them in the Themer directory to be picked up before the default Ubuntu 20.04LTS versions. The resulting files are:

- libpango-1.0.so.0
- libpango-1.0.so.0.4000.14
- libpangocairo-1.0.so.0
- libpangocairo-1.0.so.0.4000.14
- libpangoft2-1.0.so.0
- libpangoft2-1.0.so.0.4000.14
7) Since I was banging on different install methods, I had to manually make the UnityLauncher work correctly. I had to copy the /opt/Sencha/Themer/SenchaThemer.desktop file to ~/.local/share/applications directory.

Cheers!