PDA

View Full Version : Ext-gen migrate doesn't work : Found Extra positional on npm run dev



Julien RICHARD
6 Apr 2020, 6:35 AM
Hello,

I have a porject done with Extjs 6.7 classic.
Iw ant to migrate it, in order to use npm.

I foolow the docs as written =>
npm install -g @sencha/ext-gen
Then => ext-gen migrate
And npm install
At the End: npm run dev
But I have the following error :

i 「wds」: webpack output is served from /x"!
i 「wds」: Content not from webpack is served from ./:
i 「wds」: 404s will fallback to /index.html
i [ext]: [ERR] Found extra positional argument desktop
******************************************satisfied:
i [ext]: Found extra positional argument desktop

When I run the npw sencha app watch, I got te following
[ERR] Cannot satisfy requirements for "ux"!

But all dependencies were install

Thanks for your help !

westy
3 Jun 2020, 9:23 AM
I've just been trying this.

I couldn't even run 'ext-gen migrate' because it doesn't support multi-application workspaces it seems.
I also have a feeling it doesn't support the classic toolkit, but I'm not sure.

This forum seems a bit dead though eh?

Sounds like you have issues with your app requires there, since are referencing an extension, or presumably given the 'ux' requirement.