PDA

View Full Version : npm build Cannot satisfy requirements for "treegrid"



ZVONDIC
14 Nov 2019, 2:27 AM
Hi,
i added treegrid addon to EXTJS webpack project.

When i working in dev mode 'npm run dev' all works fine.

When i want to create production by 'npm run build' some error appears:


i [ext]: [ERR] Cannot satisfy requirements for "treegrid"!
i [ext]: [ERR] The following versions cannot be satisfied: [ERR] tree: treegrid (No matches!)

What can be wrong ?

Thanks Josef.

pauldugas
21 Jan 2020, 5:52 PM
Old but I recently ran into this too. "treegrid" needs to be added to the "requires" list in app.json.