PDA

View Full Version : compile error and missing package



tomdchi
10 Jul 2018, 1:26 PM
Got the error below when running npm run all


i [ext]: ext-build-util:[ERR] Cannot satisfy requirements for "ux"!

I tried to install the UX package but got a not found error


npm install -g @sencha/ext-classic-ux


npm ERR! code E404
npm ERR! 404 Not Found: @sencha/[email protected]

prefer
11 Jul 2018, 6:53 AM
Hi! You can try to install ext-ux, according to http://npm.sencha.com/

npm install -g @sencha/ext-ux
however, I've added ${workspace.dir}/node_modules/@sencha into packages section in workspace.json for proper build.