PDA

View Full Version : Cannot publish project with Sencha Architect 4.2.3.371



kramal
15 Mar 2018, 12:36 AM
Hi Everyone!

Recently I have installed Sencha Architect (4.2.3.371) and begun to create a simple app to learn basics of SA.
Unfortunatly, I have encountered a problem in very first steps. The problem is that I cannot build app with SA.

So, My steps were:

1. Create project from blank. (I have selected ExtJS 6.5 modern, not classic)
2. Just added tab panel as prescribed in docs.
3. Pushed Build web app button.

I have detected only one error in the logs
Cmd theme package failed
Name: TestApp framwork: modern65

What was wrong with my actions here?
It seems to me that I installed all things correctly.

So, I have Windows 10.

Java:
java version "9.0.4"
Java(TM) SE Runtime Environment (build 9.0.4+11)
Java HotSpot(TM) 64-Bit Server VM (build 9.0.4+11, mixed mode)

Sencha SDK
Sencha Cmd v6.5.3.6

P.S: I have repeated all steps from here in MacOS.
And as a result I have got the same error.




Thanks in advance!
With best regards,
Almas

nclemeur
12 Apr 2018, 3:58 PM
I would not be surprised if that was linked to the java version you have installed. Could you try with java 8? I haven't tried my-self, but seems that you could have some problem.
See for example: https://www.sencha.com/forum/showthread.php?469869-ERR-javax-xml-bind-DatatypeConverter

It would also help if you could post the error message. Having said that I find unbelievable that you got no response from Sencha...

Cheers
Nicolas