PDA

View Full Version : Issue with license activation and issue with reactor plugin



emaze
18 Oct 2017, 12:45 AM
Hi,
some month ago I bought a license of ExtReact, since last week when I execute "npm install --verbose" on my ExtReact project, I obtain the following exception:



> @extjs/[email protected] install /tmp/concreto/gui/node_modules/@extjs/ext-react
> node activate.js

> [activator][err]: Command failed: npm install @extjs/[email protected]
...
npm verb stack Error: No compatible version found: @extjs/[email protected]
npm verb stack Valid install targets:
npm verb stack 6.5.0-2017.5.16, 6.5.0-2017.5.15, 6.5.0-2017.5.17, 6.5.0-2017.5.18, 6.5.0-2017.5.19, 6.5.0-2017.5.20, 6.5.0-2017.5.23, 6.5.0-2017.5.24, 6.5.0-2017.5.25, 6.5.0-2017.5.26, 6.5.0-2017.5.27, 6.5.0-2017.5.28, 6.5.0-2017.5.29, 6.5.0-2017.5.30, 6.5.0-2017.5.31, 6.5.0-2017.6.1, 6.5.0-2017.6.2, 6.5.0-2017.6.3, 6.5.0-2017.6.4, 6.5.0-2017.6.5, 6.5.0-2017.6.6, 6.5.0-2017.6.7, 6.5.0-2017.6.8, 6.5.0-2017.6.9, 6.5.0-2017.6.10, 6.5.0-2017.6.11, 6.5.0-2017.6.12, 6.5.0-2017.6.13, 6.5.1-2017.6.14, 6.5.0-2017.6.14, 6.5.1-2017.6.15, 6.5.0-2017.6.15, 6.5.0-2017.6.16, 6.5.1-2017.6.16, 6.5.0-2017.6.17, 6.5.1-2017.6.17, 6.5.0-2017.6.18, 6.5.1-2017.6.18, 6.5.1-2017.6.19, 6.5.0-2017.6.19, 6.5.1-2017.6.20, 6.5.0-2017.6.20, 6.5.1-2017.6.21, 6.5.0-2017.6.21, 6.5.0-2017.6.22, 6.5.1-2017.6.22, 6.5.0-2017.6.23, 6.5.1-2017.6.23, 6.5.0-2017.6.24, 6.5.1-2017.6.24, 6.5.1-2017.6.25, 6.5.0-2017.6.25, 6.5.0-2017.6.26, 6.5.1-2017.6.26, 6.5.0-2017.6.27, 6.5.1-2017.6.27, 6.5.0-2017.6.28, 6.5.1-2017.6.28, 6.5.0-2017.6.29, 6.5.1-2017.6.29, 6.5.1-2017.6.30, 6.5.0-2017.6.30, 6.5.0-2017.7.1, 6.5.1-2017.7.1, 6.5.1-2017.7.3, 6.5.0-2017.7.3, 6.5.0-2017.7.4, 6.5.1-2017.7.4, 6.5.0-2017.7.5, 6.5.1-2017.7.5, 6.5.0-2017.7.6, 6.5.1-2017.7.6, 6.5.1-2017.7.7, 6.5.0-2017.7.7, 6.5.0-2017.7.8, 6.5.1-2017.7.8, 6.5.1-2017.7.9, 6.5.0-2017.7.9, 6.5.0-2017.7.10, 6.5.1-2017.7.10, 6.5.0-2017.7.11, 6.5.1-2017.7.11, 6.5.0-2017.7.12, 6.5.1-2017.7.12, 6.5.0-2017.7.13, 6.5.1-2017.7.13, 6.5.0-2017.7.14, 6.5.1-2017.7.14, 6.5.0-2017.7.15, 6.5.1-2017.7.15, 6.5.0-2017.7.16, 6.5.1-2017.7.16, 6.5.1-2017.7.17, 6.5.0-2017.7.17, 6.5.1-2017.7.18, 6.5.0-2017.7.18, 6.5.0-2017.7.19, 6.5.1-2017.7.19, 6.5.1-2017.7.20, 6.5.0-2017.7.20, 6.5.0-2017.7.21, 6.5.1-2017.7.21, 6.5.1-2017.7.22, 6.5.0-2017.7.22, 6.5.1-2017.7.23, 6.5.0-2017.7.23, 6.5.1-2017.7.24, 6.5.0-2017.7.24, 6.5.1-2017.7.25, 6.5.0-2017.7.25, 6.5.0-2017.7.26, 6.5.1-2017.7.26, 6.5.1-2017.7.27, 6.5.0-2017.7.27, 6.5.0-2017.7.28, 6.5.1-2017.7.28, 6.5.0-2017.7.29, 6.5.1-2017.7.29, 6.5.1-2017.7.30, 6.5.0-2017.7.30, 6.5.1-2017.7.31, 6.5.0-2017.7.31, 6.5.1-2017.8.1, 6.5.0-2017.8.1, 6.5.1-2017.8.2, 6.5.0-2017.8.2, 6.5.1-2017.8.3, 6.5.0-2017.8.3, 6.5.0-2017.8.4, 6.5.1-2017.8.4, 6.5.0-2017.8.5, 6.5.1-2017.8.5, 6.5.1-2017.8.6, 6.5.0-2017.8.6, 6.5.0-2017.8.7, 6.5.1-2017.8.7, 6.5.0-2017.8.8, 6.5.1-2017.8.8, 6.5.1-2017.8.9, 6.5.0-2017.8.9, 6.5.1-2017.9.24, 6.5.0-2017.9.24, 6.5.0-2017.10.6, 6.5.2-2017.10.6, 6.5.1-2017.10.6, 6.5.2-2017.10.7, 6.5.1-2017.10.7, 6.5.0-2017.10.7, 6.5.1-2017.10.8, 6.5.2-2017.10.8, 6.5.0-2017.10.8
...

Last available version is 6.5.2-2017.10.8. I suppose you have an issue in the activator script.
(it happens even with 6.5.1 version)


I have another issue, if I try to use reactor-webpack-plugin in order to use extjs components I obtain:


ERROR in [@extjs/reactor-webpack-plugin]: Error: Sencha Cmd version (6.5.1.240) is incompatible with required version (6.5.2.15-6.5.2.15)



Could you give me support in order to understand how to solve this issues? Currently I have installed the version with the trial watermark.

Thank you, best regards.
Andrea

tristan.lee
24 Oct 2017, 4:12 PM
Can you post what your package.json looks like?

emaze
24 Oct 2017, 10:42 PM
Hi Tristan, thank you for the response.
In my opinion it wasn't a configuration problem because with same configuration the license was correctly activated in the past.
However the first problem is now solved because the activators script works.


> @extjs/[email protected] install /home/azorzin/NetBeansProjects/concreto/gui/node_modules/@extjs/ext-react-core
> node activate.js

> [activator]: @extjs/[email protected] /home/azorzin/NetBeansProjects/concreto/gui/node_modules/@extjs/ext-react-core
└─┬ @extjs/[email protected]
└─┬ [email protected]
├── [email protected]
└── [email protected]


I solved the reactor problem using a different "non premium" component.
Have nice day.
Andrea