View Full Version : [OPEN] [Fixed in 6.5.1] Edge picker is hidden when clicking on it a second time

13 Jul 2017, 9:06 AM
The edge picker for the combobox in the material theme for the modern application hides when clicking to pick a choice from the combobox the second time.
First time it looks like this: 56611

And after I select one and want to pick another one this shows: 56612

I noticed that the style attached to the picker changes when it is clicked a second time.

The style of the picker when it is clicked the first time is this:

height: 220px; left: 0px; right: 0px; bottom: 0px; transform: translate3d(0px, 0px, 0px);

The style of the picker when it is clicked the second time is this:

style="height: 220px; left: 0px; right: 0px; bottom: 0px; transform: translate3d(16px, 253px, 0px); width: 382px;"

Notice that the transform values are different and that a width component is added. If you remove the transform and the width of the style, the picker will show like normal.

Is there anyway I can fix this now? I have tries adding css to it, but the style of the picker overrides it, even when I use the !important. Sometimes the picker won't open at all.

Thank you so much!

18 Jul 2017, 5:32 AM
Are you using Ext JS or ExtReact? I know there are some fixes related to modal/masking coming in 6.5.1. Have you tried the latest nightly?

18 Jul 2017, 6:57 AM
I am using Ext JS. I have not tried the latest nightly, I will give it a try.

Thank you!

18 Jul 2017, 6:58 AM
I just noticed I posted this bug in the ExtReact forum. Is there any way I can move it? Sorry.

18 Jul 2017, 6:12 PM
No worries, I've moved it for you.

19 Jul 2017, 2:04 AM
i have had the same problem in version 6.5.0, in 6.5.1 it seems to have been solved.

Gary Schlosberg
24 Jul 2017, 3:11 PM
Good to know. If anyone is still seeing this in 6.5.1, please post a test case.

11 Oct 2017, 12:29 PM
I have this same problem on selectfield on Ext 6.5.2 theme-material but can't reproduce it in fiddle.

if you select a value and show picker again the width is diferent


28 Sep 2018, 1:36 PM
any update/workaround on this? to reproduce this issue, use theme-material on coworkee example.

28 Sep 2018, 6:52 PM
Here is a test case https://fiddle.sencha.com/#view/editor&fiddle/2m3a

to reproduce this issue, use theme-material and configure fields with required: true and run as phone on chrome

5 Oct 2018, 12:27 PM
Thanks for the report! I have opened a bug in our bug tracker.

10 Oct 2018, 7:36 AM
Thanks Guilherme!