View Full Version : Themer Stuck On Loading Due to Socket IO

19 Jun 2017, 12:02 AM
I'm trying to get Sencha Themer 1.2 to work. I used to work with Sencha Themer 1.0 and it worked fine but now the Themer 1.2 just gets stuck at loading. When I tried to track it with fiddler, it seems that a request to Socket.IO is being blocked probably because of our compay proxy or firewall perhaps (not sure). Even though I tried setting the proxy config to point to our proxy servers, (proxy.pac) it still isn't working.
Any thoughts?


20 Jun 2017, 4:29 AM
That looks like the request to load the socket.io JS file. Themer is an Electron app, so it's basically a Node server + chromium browser. That file is served locally by Themer (server) to an iframe within Themer (renderer) (which contains the 'Preview' app in the center). This was changed in 1.0 to 1.1 when we added inspecting apps in browsers, the Preview app is treated like just any other app Themer can manage (and socket.io is used for that management--previously we used iframe messages instead).

In any event, you can see it's not hitting a remote URL (localhost:8900), so the proxy shouldn't make a difference. It sounds like you had the same (or similar) error without the proxy setting? If that's the case, my only guess would be some sort of local firewall policy that is preventing Themer from serving files locally (or specifically on that port range). If you know of any good port Themer can operate on, you can set the 'base port' in the settings as well. This will force Themer to try to use a different port on startup.

20 Jun 2017, 4:51 PM
I got it fixed by setting the base port to 8900. Not sure how that fixed it though.
Thanks for the insight anyway.

21 Jun 2017, 4:42 AM
That is interesting since I think that's the default port. Glad it's working though! :)

4 Jul 2017, 9:50 PM
Thanks beefporky, it worked for me as well :)
I lost almost a day to fix this.