View Full Version : [CLOSED] Cannot get reactor-boilerplate started

18 May 2017, 10:32 AM
I have tried everything and i cannot get past the 2nd step (Creating a new application (http://docs.sencha.com/extreact/6.5.0/guides/getting_started.html#getting_started_-_creating_a_new_application)) in the Getting Started (http://docs.sencha.com/extreact/6.5.0/guides/getting_started.html) guide...

I have posted a comment on this issue in github (https://github.com/sencha/extjs-reactor/issues/203#issuecomment-302467238) which seems very similar. Have a look there for the real details but essentially, when I run npm start it just hangs with the same error message each time...

10% building modules 1/1 modules 0 active
Project is running at http://localhost:8080/
webpack output is served from /
Content not from webpack is served from ./build
404s will fallback to /index.html
94% asset optimization
building ExtReact bundle: ext => C:\sandbox\extjs-reactor\packages\reactor-boilerplate\build\ext-react
(node:5256) UnhandledPromiseRejectionWarning: Unhandled promise rejection (rejection id: 1): TypeError: Cannot read property 'toString' of undefined

I'm almost certain this is caused by some issue with sencha-cmd (see here (https://github.com/sencha/extjs-reactor/issues/203#issuecomment-302467238) for more analysis and evidence). This is a real pity as I was so looking forward to ExtReact and I can't even get it started.

18 May 2017, 12:23 PM
The issue was indeed related to sencha-cmd. However, it was actually the JRE version which caused the error. Thanks to @israelroldan's suggested solution here (https://github.com/sencha/extjs-reactor/issues/203#issuecomment-302509371).

I upgraded Java to latest version (8), deleted node_modules/reactor-boilerplate folder (just to make sure I had a clean install) and then ran npm install followed by npm start. Everything worked perfectly this time.

Gary Schlosberg
18 May 2017, 1:17 PM
Glad to hear that you got things working, and thanks for sharing the solution here with the community.