View Full Version : [OPEN] Uncaught Exception: Error: Unable to find a valid app

3 Apr 2017, 4:17 PM
Since I let Architect update itself the other day (this is the first time I've tried to start it since then), I'm getting the following error


I'm on Windows 10. I also tried browsing to the EXE itself (rather than the start menu icon) and I get the same error.

4 Apr 2017, 6:18 AM

I am sorry for the troubles. If you want to get SA working ASAP please follow these instructions https://www.sencha.com/forum/showthread.php?337049-Can-t-start-architect&p=1175227&viewfull=1#post1175227

If you have little time, if you could share few details about your installation because we are unable to reproduce and find cause of this problem :(

Could you share the content of the C:\Program Files\Sencha\Sencha Architect 4.1.2\resources\config.json

There should be something like this:

"installedVersion": "",
"runtimesPath": "C:\\Program Files\\Sencha\\Sencha Architect 4.1.2-nightly\\runtimes",
"updatesPath": "%LOCALAPPDATA%\\Sencha\\Sencha Architect Updates"

If you look at the updatesPath which you have there, do you have any folders there?

Also if you could remember which auto-updates you did - it would be great help... Like perhaps you installed 4.0.1 and than auto-update to 4.0.2 -> 4.1.0 -> 4.1.1
4.0.2 -> 4.1.1

Btw did you see any error during update?

Thank you very much

4 Apr 2017, 4:36 PM
I checked my config.json (C:\Program Files\Sencha\Architect4\resources\config.json) and it contains this:

"installedVersion": "",
"runtimesPath": "C:\\Program Files\\Sencha\\Architect4\\runtimes",
"updatesPath": "%LOCALAPPDATA%\\Sencha\\Sencha Architect 4.0\\updates"

Here's a picture of the contents of the updates folder (C:\Users\mfearby\AppData\Local\Sencha\Sencha Architect 4.0\updates):


I'll have a look now at that link you posted and post an update with the results. Thanks.

4 Apr 2017, 4:40 PM
I deleted the contents of my updates folder (as per advice in that other link) and it's still complaining about being unable to find a valid app. I suppose I'll try uninstalling and going back a version.

4 Apr 2017, 4:45 PM
Hmm. I guess there'll be no downgrade for me because I can no longer log into the support portal.


My license isn't due for renewal until June.

Edit: it would seem that the original email address is now required. For a time there I had to log in with "marc.fearby" and it wouldn't take that email address, but now it's decided to change things around again... because, boredom I guess :-)

Edit 2: Um, nope. That old login gives me Cmd and Sencha Touch. "No download for you. Come back, One year" :-(

5 Apr 2017, 12:34 AM
Hi Marc

Go to the installed folder program files, SenchaArchitect4/ and delete folder runtimes. Now when you start SA, it should start with the version you have installed the first time. You should again get trigger about auto-update. And you can try again run auto-update.

5 Apr 2017, 3:24 PM
Thanks Petr. I did that and it re-updated itself, started successfully, and even after rebooting my computer it starts OK this time.

7 Apr 2017, 5:21 AM
Deleting the runtimes folder worked for me too, +1

7 Apr 2017, 5:49 AM
I see. Thank you for letting us know. .We think we found the root of this issue. Logged as DSGNR-7724