View Full Version : Uncaught ReferenceError: io is not defined

25 Jan 2017, 3:53 PM
When using sencha Inspector Bookmarklet 6 with extjs 5 and try to connect I get the following error:

Uncaught ReferenceError: io is not defined
at f (inspector.js:1)
at d (inspector.js:1)
at Object.onLoadSuccess [as success] (ext-all-debug.js:11448)
at Request.notify (ext-all-debug.js:1085)
at Request.processLoadedEntries (ext-all-debug.js:1064)
at Entry.notifyRequests (ext-all-debug.js:1534)
at complete (ext-all-debug.js:1369)
at HTMLScriptElement.<anonymous> (ext-all-debug.js:1372)

27 Jan 2017, 12:22 PM
Can you try with Chrome or Safari? Are you able to connect examples to Inspector?

27 Jan 2017, 2:07 PM
I have tried with Chrome, Firefox, and IE.
How do I connect examples to Inspector? Do I put the address in the Advance Settings of Bookmarklet?
I can not connect to the demo app.

27 Jan 2017, 2:56 PM
I assume you have bookmarklet created in Chrome. If not, follow steps in guide to create it
Then load example in the browser. For e.g.
http://examples.sencha.com/extjs/5.1...ard/index.html (http://examples.sencha.com/extjs/5.1.3/examples/executive-dashboard/index.html)
Click on the bookmarklet, the app entry should be now shown in Inspector and you can click to start inspecting example app.

The Demo app will not work as it was using google feed APIs that is now not available.

27 Jan 2017, 3:15 PM
Ok, that worked, thanks. Now I have an application that is running on http://localhost:5000 in Chrome. When I do the same steps as I did for the example I get the "io is not defined". How do I connect http://localhost:5000 to the inspector?

30 Jan 2017, 6:29 PM
There may be scoping issue with socketio. I have opened a bug INS-383 in our bug tracker.

The workaround is to find the dependency(s) in your app, and remove the conflict somehow. This will be different depending on the dependency causing the conflict.