View Full Version : Working with Themer - App won't start after $ sencha app watch -fashion classic

5 Jan 2017, 7:58 PM
Having trouble with my application and the Themer.. so I generated a new "MyApp" starter app.
I then ran sencha app watch -fashion classic
I then ran the Themer & made a few changes to the titan theme.
the "watcher" did its trick & rebuilt the app...

I then tried running the app & got this error

GET http://localhost/~sass/register?location=http%3A%2F%2Flocalhost%2FMyApp%2Findex.html&phantomjs=false 404 (Not Found)
doRequest @ sass-compiler.js?_dc=1483674070458:107
requestFn @ sass-compiler.js?_dc=1483674070458:355
beginLiveUpdateMonitor @ sass-compiler.js?_dc=1483674070458:369
(anonymous) @ sass-compiler.js?_dc=1483674070458:403

tried hard reseting caches, clear browser history etc. Still no good.

If I build the app using $ sencha app build classic
all is OK.

I then re-tried the $ sencha app watch -fashion classic
restarted the app & saw the message saying the app has been upgraded. OK. but then get the 404 error again!!

Is seems this could be an environment issue: possible cmd isn't mapping ~sass to my localhost directory correctly?
I map my localhost to a folder called "Sites"
Mac Sierra
ExtJS & cmd 6.2.1

6 Jan 2017, 4:23 PM
I then tried running the app & got this error

Does this mean you restarted app watch against the starter app you generated, did you somehow have 2 app watches running against the same app? If it was a different app, have you ever successfully run app watch against it before Themer go involve?

I think it may be quickest/easiest for me to help debug this issue if you could send me your workspace. Let me know if this is reasonable to you, and I'll shoot you an email so you can send it that way.

Thanks and I hope we can get this worked out for you!