View Full Version : [FIXED] Themer says "no settings exist for the selected component"

8 Dec 2016, 12:06 PM
Hi - I used Themer 1.0.3 to make some changes to my application theme, and it worked fine, but now when I open the theme in Themer I get the message "no settings exist for the selected component" for every component, and no SASS variables are ever listed. I believe this may have been triggered by some minor manual changes I made to some of my SASS - but I havent been able to track down what could have caused Themer to break.

There's no error message displayed in the Themer.log.

How can I resolve this issue and use Themer again?

- bill

12 Dec 2016, 6:27 AM
Hi Bill,

That sounds like a Fashion error (and a bug in Themer for not reporting it). Can you try running `sencha app watch -fashion` from the command-line against the Preview App ([theme_dir]/.sencha/temp/Themer). Alternatively, I sent you an email if you want to reply with your Theme package and I can take a look.

Either way, it would be good for us to understand your issue and make sure it's not a bug in Themer or Fashion.

12 Dec 2016, 6:36 AM
Hi Dan - thanks for replying. Interestingly when I run 'sencha app watch -fashion' against [theme_dir]/.sencha/temp/Themer no error is reported, and the app (well, the login dialog) displays fine at http://localhost:1841

I've replied to your email with a copy of the theme...

- bill

12 Dec 2016, 8:39 AM
Looks like this is a bug with Themer. It appears you defined a UI in the 'save' directory, but Themer does not know how to handle that UI (yet) and is failing.

If you move your tabpanel UI to sass/src/Ext/tab/Panel.scss instead, Themer should load again.

I only checked the 'classic' toolkit in your Theme, a similar modification would be necessary if you made changes like this in modern.

12 Dec 2016, 12:16 PM
Perfect - that fixed the problem. Thanks.