View Full Version : [FIXED] Editing a created group

28 Nov 2016, 12:50 AM
I played around with groups today, I created one and then tried to edit it.

I noted the following issues when I tried to edit the group:

Changing the group name does not activate the save button (missing dirty binding?)
The wording of the "Create" button caption could be improved, so that it's intuitive what it would create.
Given the title "Fiddles" over the "Create" button, I would have inferred that I would create a Fiddle when I click this button. However I was lead to a user selection with permissions instead. When I tried to add a user, no obvious change was visible in the group dialog. However at least the save button became active.¨
When I finally tried the (by now active) "Save" button, I got a JS error on the console which was "Uncaught TypeError: Cannot read property 'creator' of undefined". The callstack output in Chromium was

app.js?_dc=20161124101903:3 Uncaught TypeError: Cannot read property 'creator' of undefined

onSave @ app.js?_dc=20161124101903:3
callback @ framework.js?_dc=20161124101903:1
fireHandler @ framework.js?_dc=20161124101903:1
onClick @ framework.js?_dc=20161124101903:1
fire @ framework.js?_dc=20161124101903:1
fire @ framework.js?_dc=20161124101903:1
publish @ framework.js?_dc=20161124101903:1
publishDelegatedDomEvent @ framework.js?_dc=20161124101903:1
doDelegatedEvent @ framework.js?_dc=20161124101903:1
onDelegatedEvent @ framework.js?_dc=20161124101903:1
(anonymous function) @ framework.js?_dc=20161124101903:1


28 Nov 2016, 5:14 AM
Given the reply in this thread (https://www.sencha.com/forum/showthread.php?331961-What-are-group-for-existing-group-useful-in-some-way&p=1166534&viewfull=1#post1166534), I assume that this button should not provide a user selection dialog, but that
* I should get a Fiddle selection to add a Fiddle to the group when clicking that button and that the button should be captioned with "add Fiddle"
* clicking the button should execute an action that leads to the creation of a new Fiddle, which is then assigned to that group

28 Nov 2016, 6:21 AM
The editing bug is resolved.