View Full Version : Sencha Test Browser not starting when runnning tests from Studio

Werner Hihn
24 Nov 2016, 3:22 AM

I installed the EA build, created a new workspace (see my workspace.json) and added one simple test.


"name": "sencha-test",
"build": {
"dir": "${workspace.dir}/build"
"packages": {
"dir": "${workspace.dir}/packages/local,${workspace.dir}/packages",
"extract": "${workspace.dir}/packages/remote"
"tests": {
"path": "test\\project.json"


"framework": "jasmine",
"libs": [],
"coverageFilters": [],
"scenarios": [
"libs": [],
"coverageFilters": [],
"sandbox": true,
"directory": "E2E",
"name": "E2E"
"subjectUrl": "https://www.google.com/",
"globals": "*"

When I select my scenario, I only see one embedded browser (Google Chrome 54), so I select that. In version 1 the browser was already started at that point, but that doesn' t happen here.
So I press the Run button, in the upper right corner I'm seeing "Loading Tests", but nothing happens. It doesn' t even help to click "Start embedded".
No error messages in the logs, just this:

1 0:00:00.238 [INF] Version (Build date 11/07/2016)
2 0:00:00.423 [INF] Parking Lot open on port 8800
3 0:00:02.029 [DBG] environment: orion (tern v{build})
4 0:00:02.181 [DBG] found config.json at C:\Users\whihn\workspace_svn19\sencha-test\.sencha\ide\config.json
5 0:00:02.184 [DBG] contents:
6 0:00:02.184 [DBG] {}
7 0:00:02.186 [DBG] include [ 'C:\\Users\\whihn\\workspace_svn19\\sencha-test',
8 0:00:02.186 [DBG] 'C:\\tools\\sencha_test_2_0_0_287\\resources\\app.asar\\node_modules\\orion-core\\serve' ]
9 0:00:02.187 [DBG] contents after postprocessing:
10 0:00:02.187 [DBG] {
11 0:00:02.187 [DBG] "include": [
12 0:00:02.187 [DBG] "C:\\Users\\whihn\\workspace_svn19\\sencha-test",
13 0:00:02.187 [DBG] "C:\\tools\\sencha_test_2_0_0_287\\resources\\app.asar\\node_modules\\orion-core\\serve"
14 0:00:02.187 [DBG] ],
15 0:00:02.188 [DBG] "apps": [],
16 0:00:02.188 [DBG] "exclude": []
17 0:00:02.188 [DBG] }
18 0:00:02.189 [DBG] Found apps: []
19 0:00:02.231 [DBG] loading 39 js files in project...
20 0:00:03.347 [DBG] project loaded in 1.132 seconds
21 0:00:03.374 [DBG] wrote indexes
22 0:00:03.375 [DBG] Listening on port 54496
23 0:00:04.932 [INF] Proxy Server open on port 8000

I had Sencha Test 1 installed before, but I uninstalled that and removed old settings in <user_home>/.sencha.

Any help would be highly appreciated.

Werner Hihn

24 Nov 2016, 7:27 PM

The first thing we need to verify is the the embedded selenium server instance is getting started correctly. Can you look in the Tasks tab within Studio and confirm that you have an entry like so:

Selenium Server @4450

When you run the tests, the embedded server *should* be started automatically, so there may be an issue getting that spun up, which is then preventing the rest of the process from completing successfully.

Once you confirm that the task is running correctly, try navigating to this url in your browser:

If the page resolves and you see a "WebDriver Hub" page, that will confirm that the selenium server instance is running correctly.

If you are not able to see the task or access the WebDriver hub url, that would indicate that there is indeed an issue starting up the server. If so, let me know and we can further explore this issue.


Werner Hihn
25 Nov 2016, 12:09 AM
Hi Joel,

thanks for looking into this. Selenium Server seems to start as expected, I see the entry in Tasks Tab and the WebDriver hub URL displays a page, where I can create & refresh sessions.

Nevertheless, the Location-URL from my project settings is never loaded.

Regards, Werner

29 Nov 2016, 8:24 PM

Please notice the double backslash in your workspace.json:

"tests": {
"path": "test\\project.json"

Try replacing it with a single forward slash like this:

"tests": {
"path": "test/project.json"

Let me know if that solves the problem. Also, was it generated by Sencha Test (in which case it would be a bug we have to fix) or it was edited manually?


Werner Hihn
30 Nov 2016, 5:20 AM

yes, the double backslash was generated by Sencha Studio, I already mentioned that in a support ticket for version 1:
#32659 "No test scenario found on when running via STC"

Changing it to a single forward slash fixed the issue I had then, but it doesn' t fix the current problem :(

Regards, Werner

Werner Hihn
3 Feb 2017, 12:58 AM
Works fine now with release version 2_0_0_359

21 Feb 2018, 5:07 AM
Hi Marcelo,

I'm having similar issue with version
Selenium Server @ 4451 Running: No

The Power switch icon next to Embedded in blinking green but Selenium does not start.

Here is the error in the Log:
[ERROR] [model/farm/Embedded] Error: Unable to connect to selenium at hasStarted (C:\Program Files\Sencha\Test\2_2_0_111\resources\app.asar\node_modules\orion-core\node_modules\selenium-standalone\lib\check-started.js:17:10)

Unable to connect to selenium

Tried editing the workspace.json as you suggested, no luck.

Please advise.