View Full Version : Fiddle currently broken?

22 Nov 2016, 10:49 AM
Nevermind, all appears to be OK. All of the links I clicked were for dead examples which no longer functioned.

22 Nov 2016, 10:50 AM
There was another thread about this but didn't look for it.

Short answer, it's a bug.

Long answer, there is some code to detect if there is something like Ext.application() or Ext.onReady() that is failing therefore your code is not waiting for Ext JS to be ready. If you wrap your code in Ext.onReady or the like then it will work.

23 Nov 2016, 10:41 AM
Fiddle appears broken to me, there's an exception in console when I open main page (https://fiddle.sencha.com).

app.js?_dc=20161123001903:3 Uncaught TypeError: Cannot read property 'get' of null(…)

23 Nov 2016, 12:14 PM
Fiddle is loading and running just fine for me. I know it's minified but of course that error doesn't give much info to go off on.

23 Nov 2016, 12:23 PM
Cleared cache in chrome, still doesn't work. Checked clean FF also no luck. Here's a screenshot

23 Nov 2016, 12:27 PM
Looks like the framework catalog didn't load. Could you look and see if any requests to https://api.sencha.com/v1.0/direct/router timed out? There should be 4 of them on app startup and the frameworks are the third one for me.

23 Nov 2016, 12:42 PM
Here are 4 screenshots of requests. I cleaned cookies to *.sencha.com, cache is clean.

Also I can view old fiddles, but I cannot create new with 'add' button or navigate successfully to main page, as you see here.

23 Nov 2016, 12:55 PM
When navigating to https://fiddle.sencha.com the following errors appear in the console (Safari):

TypeError: null is not an object (evaluating 'w.get')

XMLHttpRequest cannot load https://api.sencha.com/v1.0/direct/router?system=forum&%24app=fiddle.
Origin https://fiddle.sencha.com is not allowed by Access-Control-Allow-Origin.

24 Nov 2016, 10:18 AM
Try it now. For more info: https://www.sencha.com/forum/showthread.php?332448-Sencha-Fiddle-Unresponsive&p=1166414&viewfull=1#post1166414

Back to my holiday off :)

24 Nov 2016, 2:01 PM
Yes it works now. Thanks for the great work!