PDA

View Full Version : [OPEN] Can't specify $base-highlight-color in Sencha Architect 4.0.1



marc.fearby
25 Sep 2016, 8:16 PM
I tried to type this in the "Filter Configs" box then click "Add" to get it in there, but it seems to have permanently added itself to my Triton theme as the following and I can't remove it:


$base-highlight-color: false;

As a result, trying to build my app/theme is crashing spectacularly with hundreds of errors, but this seems the most relevant to post here:


[ERR] arg 1 false is not a color for 'mix'
[ERR] [email protected]://platform/fashion-phantomjs.js:5:10951

I've removed the offending line from the following file, saved, and reopened Architect 4.0.1, but this setting is somehow still there. How do I get rid of it? It must be obfuscated in another file somewhere because I've even used a tool to search the contents of all files and still can't find it.

packages\local\theme-triton-95542602-0b17-41a4-b703-7646c7b561fa\sass\var\Component.scss

marc.fearby
25 Sep 2016, 8:37 PM
I found it in a file corresponding to the name of my theme in metadata\resource. I was searching for the variable name including the dollar sign, which is why I didn't find it here before:


"user-globals": {
"globalVars": [
{
"name": "base-highlight-color",
"displayName": "base highlight color",
"enabled": true,
"value": "false",
"type": "unknown",
"userDefined": true
}
]
}

petr.felzmann
27 Sep 2016, 4:18 AM
Thanks for the report! I have opened a bug in our bug tracker.

grosst
5 Oct 2016, 8:46 AM
I tried to type this in the "Filter Configs" box then click "Add" to get it in there, but it seems to have permanently added itself to my Triton theme as the following and I can't remove it:


$base-highlight-color: false;

As a result, trying to build my app/theme is crashing spectacularly with hundreds of errors, but this seems the most relevant to post here:


[ERR] arg 1 false is not a color for 'mix'
[ERR] [email protected]://platform/fashion-phantomjs.js:5:10951

I've removed the offending line from the following file, saved, and reopened Architect 4.0.1, but this setting is somehow still there. How do I get rid of it? It must be obfuscated in another file somewhere because I've even used a tool to search the contents of all files and still can't find it.

packages\local\theme-triton-95542602-0b17-41a4-b703-7646c7b561fa\sass\var\Component.scss

as a work around... instead of false, try using rgba(0,0,0,0) for transparent.

marc.fearby
5 Oct 2016, 1:06 PM
as a work around... instead of false, try using rgba(0,0,0,0) for transparent.

When I tried to add the setting manually it defaulted to false, and I couldn't change it. So now that I've eradicated it, I'm just getting through life one day at a time without it :-)