PDA

View Full Version : [OPEN] 6.2.0 and 6.0.2 Docs are not accessable "403 Forbidden"



Mr-Money
20 Sep 2016, 12:05 AM
55131 55132
5513355134

http://docs.sencha.com/extjs/6.0.2/classic/
http://docs.sencha.com/extjs/6.2.0/classic/


Edit:
Every time i hit f5 i get a other page.

1. 403 Forbidden
2. html without any css
3. with css but fonts are missing
3. normal api docs

looks like a deploying problem

SebTardif
20 Sep 2016, 4:29 AM
It seems one time on two, I guess you have a cluster of two servers, and one is bad. If your monitor anything, you should already have received an alert that your system is not working. If you use AWS, it's easy to automatically detect one server is bad, and then automatically route only to the one working...

bhutten
20 Sep 2016, 4:41 AM
I'm seeing this as well - 6.0.2 Modern API docs work, classic does not. Many other examples as well.

pbienick
20 Sep 2016, 5:04 AM
This is killing me this morning. Anyone know if I can download the docs from somewhere?

Mr-Money
20 Sep 2016, 5:15 AM
i have found the offline docs for download

http://docs.sencha.com/misc/guides/offline_docs.html

i have tested again and 2 out of 10 times the docs are working

pbienick
20 Sep 2016, 5:28 AM
Thanks, Mr-Money. I had to refresh that page numerous times to get it to come up. For me, I get the 403 Forbidden about 50% of the time.

mitchellsimoens
20 Sep 2016, 5:41 AM
I've restarted the server instances and things look good for now. Can you confirm?

Hmm, getting random 404 for the offline doc list. This may have to wait for the engineers responsible for the docs to come online.

pbienick
20 Sep 2016, 5:44 AM
Seems to be working fine now, Mitchell. Thanks.

ebarber
20 Sep 2016, 8:28 AM
Thanks Mitchell, ExtJS 6 docs are back up and working, but it appears the same issue is affecting Touch docs. Anyone else seeing the same thing?

mitchellsimoens
20 Sep 2016, 9:27 AM
Sorry, our IT guy is out sick today and I only have a certain amount of knowledge to how this project is laid out. We saw a few files were missing so we did another incremental deployment which seems to have things back up for the moment. The touch and offline docs are now online for me currently.

ebarber
20 Sep 2016, 9:36 AM
Great, thanks Mitchell, it's working for me as well

greg.barry
20 Sep 2016, 10:40 AM
Hey guys,

Sorry for the downtime. The issue was related to our server instances being out of sync. Luckily, Mitch was able to get the instances back up.

The content has been re-synced from our deployment environment and I believe everything is back up and running.

Really sorry for the inconvenience.

Thanks!
Greg