View Full Version : Can't found test scenario when running Sencha Test by CLI

29 Jul 2016, 3:11 AM

I have a simple app sencha generated from command "sencha -sdk /path/to/extjs/framework generate app AppName path/to/app".
In the Sencha Studio, I can run these test scenarios successfully, but when I tried by using CLI, it didn't work.

I followed the guides to install the nodejs and config the PATH for stc.

I 'd tried to run

stc run -o text -p "chrome" -s AppName\test\uiTest
and then I got the error: No test scenario found on <path to \AppName\test\uiTest>

Any suggestion?

29 Jul 2016, 7:27 PM
Are you running the latest stc version? There was a very similar issue reported a while back, and it should be fixed on 1.0.3.

2 Aug 2016, 9:33 PM

I was downloaded Sencha Test version 1.0.3 from the server, but the version of the stc according to the package.json is 1.0.0. It right?

And how I can update stc to the last version?

3 Aug 2016, 5:01 AM
Thank you. I have try this one https://www.sencha.com/blog/using-sencha-test-with-jenkins-and-selenium-grid/ and it works.