PDA

View Full Version : Visual Studio 2015 Enterprise Crashing When Sencha Plugin Enabled for Project



Bechard101
5 Jul 2016, 5:49 AM
When I click and drag a file to add it to Visual Studio 2015 Enterprise Update 2 and 3 or perform any file operations it hangs and then I must end the process. When I disable Sencha plugin for that project it will work without issue.

I've tried re-installing the latest and greatest Sencha plugin as well as a re-install of Visual Studio without any luck.

Any ideas what I could do to resolve?

mirekgrela
6 Jul 2016, 11:19 PM
Hi, can you post content of plugin log file? It could help with troubleshooting. Log file is located here: c:\Users\{user_name}\AppData\Local\Microsoft\VisualStudio\14.0\Extensions\{random folder}\Logs\{date}.log

Bechard101
7 Jul 2016, 5:09 AM
Thanks for the suggestion, however, there was no folder located at c:\Users\{user_name}\AppData\Local\Microsoft\VisualStudio\14.0\Extensions. There were only 2 Cache files and an XML file.

In order to install I had to run the following command since I can't run .exe files in app data. I believe it should be somewhere in programdata as a result, but nothing ending in .log was found related to Sencha or Visual Studio.


C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\VSIXInstaller.exe C:\Users\Bechardtm\Desktop\SenchaVS.vsix /admin

mirekgrela
7 Jul 2016, 5:52 AM
It seems, that you install Sencha plugin as admin extension. Can you uninstall it and then install it using Visual Studio UI? Go to menu - Tools / Extension and Updates, then search in Visual Studio Gallery "Sencha Visual Studio Extension", then install it.

Bechard101
7 Jul 2016, 6:08 AM
Unfortunately I cannot do that. Due to a policy at my organization we cannot run .exe files in the appdata folder which results in Visual Studio failing.

Bechard101
7 Jul 2016, 11:14 AM
Good Afternoon,I've resolved the issue, but at the expense of reduced functionality in Visual Studio. I've went under script/_references.js and turned off autosync. From there i removed all references to the Sencha Files. Then I added ext-all.js so that I could still get code completion. I am now seeing a reduction in RAM and vast increase in performance.The drawback with this, is that I now need to manually maintain that file every time a script is added if I want inteli-sense.

Mark.Brocato
29 Jul 2016, 10:55 AM
We recently released v6.0.5 of the Ext JS Visual Studio plugin to address memory consumption. If you have not already done so, we suggest upgrading to that version.

The only way to affect which files the plugin indexes is to edit the .sencha/ide/config.json file in the root of your solution. You can access this file by right-clicking on the solution in the project tree in Visual Studio and selecting "Edit Sencha IDE Config File".

The plugin will automatically exclude any minified build artifacts such as ext-all.js to increase speed. This means that in order for intellisense to work you need to have the full Ext JS unminified source code somewhere in your solution. If you used Sencha Cmd to create your app or workspace, this is done automatically. Otherwise, uncomment the "apps" array at the bottom of the config file and add an entry describing the location and nature of your Ext JS app. Here's an example:



"apps": [{
"name": "MyExtApp",
"path": "Project\\path\\to\\MyExtApp",
"toolkit": "classic",
"sdk": {
"path": "c:\\path\\to\\sencha\\ext-6.0.2",
"version": "6.0.2",
"framework": "extjs"
}
}]


Paths are relative to the root of the solution. You can use a full path for the SDK if it is located outside of your solution.

You'll need to close and reopen the solution for these changes to take affect. You'll know intellisense is working properly when you see the Sencha logo next to items in the IntelliSense menu.