PDA

View Full Version : Visual Studio plugin - problem and why is it needed



bluesky100
20 May 2016, 1:29 AM
Dear all,

my first quesiton is what is the need for visual studio plugin?
is it necessary?
do I need to develop extjs apps?
another thing is after I download and try to install it I get following error - despite having visual studio 2012 premium installed.

5/20/2016 1:29:00 PM - Microsoft VSIX Installer
5/20/2016 1:29:00 PM - -------------------------------------------
5/20/2016 1:29:01 PM - Initializing Install...
5/20/2016 1:29:02 PM - Extension Details...
5/20/2016 1:29:02 PM - Identifier : SenchaVSIX.Company.39048217-955a-4402-84e9-8a24f0730e74
5/20/2016 1:29:02 PM - Name : Sencha Visual Studio Extension
5/20/2016 1:29:02 PM - Author : Sencha, Inc.
5/20/2016 1:29:02 PM - Version : 6.0.4.467
5/20/2016 1:29:02 PM - Description : Sencha Ext JS Visual Studio Extension
5/20/2016 1:29:02 PM - Locale : en-US
5/20/2016 1:29:02 PM - MoreInfoURL : http://docs.sencha.com/ide_plugins/visual_studio_ide_plugin.html
5/20/2016 1:29:02 PM - InstalledByMSI : False
5/20/2016 1:29:02 PM - SupportedFrameworkVersionRange : 4.5
5/20/2016 1:29:02 PM -
5/20/2016 1:29:02 PM - Supported Products :
5/20/2016 1:29:02 PM - Microsoft.VisualStudio.Pro
5/20/2016 1:29:02 PM - Version : [12.0,15.0)
5/20/2016 1:29:02 PM - Microsoft.VisualStudio.Premium
5/20/2016 1:29:02 PM - Version : [12.0,15.0)
5/20/2016 1:29:02 PM - Microsoft.VisualStudio.Ultimate
5/20/2016 1:29:02 PM - Version : [12.0,15.0)
5/20/2016 1:29:02 PM - Microsoft.VisualStudio.Community
5/20/2016 1:29:02 PM - Version : [12.0,15.0)
5/20/2016 1:29:02 PM - Microsoft.VisualStudio.Enterprise
5/20/2016 1:29:02 PM - Version : [12.0,15.0)
5/20/2016 1:29:02 PM -
5/20/2016 1:29:02 PM - References :
5/20/2016 1:29:02 PM - -------------------------------------------------------
5/20/2016 1:29:02 PM - Identifier : Microsoft.VisualStudio.MPF.12.0
5/20/2016 1:29:02 PM - Name : Visual Studio MPF 12.0
5/20/2016 1:29:02 PM - Version : [12.0,13.0)
5/20/2016 1:29:02 PM - MoreInfoURL :
5/20/2016 1:29:02 PM - Nested : No
5/20/2016 1:29:02 PM -
5/20/2016 1:29:02 PM -
5/20/2016 1:29:02 PM - Searching for applicable products...
5/20/2016 1:29:02 PM - Found installed product - Microsoft Visual Studio Premium 2012
5/20/2016 1:29:02 PM - Found installed product - Microsoft Visual Studio Professional 2012
5/20/2016 1:29:02 PM - Found installed product - Microsoft LightSwitch for Visual Studio 2012
5/20/2016 1:29:02 PM - Found installed product - Microsoft Visual Studio 2012 Shell (Integrated)
5/20/2016 1:29:02 PM - Found installed product - Global Location
5/20/2016 1:29:02 PM - Found installed product - ssms
5/20/2016 1:29:02 PM - VSIXInstaller.NoApplicableSKUsException: This extension is not installable on any currently installed products.
at VSIXInstaller.App.InitializeInstall()
at System.Threading.Tasks.Task.InnerInvoke()
at System.Threading.Tasks.Task.Execute()



Can someone help?

Gary Schlosberg
20 May 2016, 6:32 AM
The Visual Studio plugin requires VS 2013 or VS 2015.
https://docs.sencha.com/ide_plugins/visual_studio_ide_plugin.html

bluesky100
20 May 2016, 8:00 AM
I decided to go with Sencha architect, in that case I don't need that plugin right?

Gary Schlosberg
20 May 2016, 12:31 PM
Yes, you should only need the plugin if you are planning to use the Visual Studio IDE.