View Full Version : [FIXED] Running tests of packages in CLI

11 Mar 2016, 6:46 AM

We have some packages what are used in different applications.
In this packages are defined test scenarios.
From Sencha Studio I'm able to run these scenarios, but not from CLI.

If I try to run
stc run -o text -p "ourSeleniumPool" -s "packages/local/ourPackageName/test/unit" -c ourBackIP
then I get error: No test scenario found on pathToPackageTestFolder

Any suggestion?

13 Mar 2016, 11:27 PM
Thanks for the report! I've moved the ticket from Q

16 Mar 2016, 10:31 AM

I'm trying to reproduce the problem you're seeing.

A brief checklist:
- Check if you're using the latest Sencha Test 1.0.1
- Does "packages/local/ourPackageName/test/unit" exist relative to the dir where stc is being invoked? (If you do ls "packages/local/ourPackageName/test/unit", will it find the dir?)
- Check scenario path for case sensitivity - perhaps it's being strict about lowercases/uppercases

Once you verify it, would it be possible to share a minimal workspace in which the problem can be reproduced?

17 Mar 2016, 7:52 AM
Yes, I downloaded the sts-1.0.1 from your server. Funny, but the version of the stc acording to the package.json is 1.0.0.

I attached a screenshot from my machine with the consol, folders, and opened files.
First I ran the test of the application (it was successfull).
After that I ran the test in the package (it was not found).
As you see the files are there.

Any idea?

17 Mar 2016, 1:58 PM
Thanks for the information! I've tried to re-create your environment and in fact I did see an error with stc 1.0.0 and 1.0.1, although it was *not the same* you're facing. I'm using the latest nightly build in the example below.

This is a screenshot of my setup (it's a freshly generated workspace), where I've tried to mimic yours. Do you see any differences that I might have overlooked?


18 Mar 2016, 12:49 AM

When I updated the stc to the nightly build, I was able to run the package test, but only once. After that it worked same as before. Second time on run I get the test not found in the given folder...

24 Mar 2016, 1:07 PM
I'm wondering what could have possibly changed between executions so they gave different answers. Does which stc give you the same path in both cases? Also, does it make any difference whether you use full qualified path to the stc executable?

25 Mar 2016, 12:09 AM
It was totally weird, because I ran the two try after each other. Wasn't any difference or changes between them, just get back the previous command in the console and restarted.

Otherwise we stepped over on this problem, because the package was moved into a separated branch in a small app, and now it's functions are tested from that small app automatically from Jenkins, and the package is created from same job into the remote repository.

But of course the original bug is still deep inside the stc code ;)

25 Mar 2016, 11:08 AM
Glad you found a workaround for the time being. Unfortunately, I still can't reproduce the problem, as you can see in the screenshot, but will keep looking.

If you have any more information about the problem in the future or a test case you can share, please let us know.


2 Aug 2016, 8:00 PM
Hi stevesum (https://www.sencha.com/forum/member.php?539976-stevesum),

I have the same issue with you.
I was downloaded Sencha Test 1.0.1 and 1.0.3, but the version of the stc according to the package.json is 1.0.0.
Please let me know how to update stc to the last version?