PDA

View Full Version : Plugin very slow



123132
7 Mar 2016, 2:07 AM
Hi,

are there any known problems with the performance of the ide-plugin?
Its very slow, espacially the intelligence. While auto-complete with intelligence VS stops working sometimes and needs a restart.

environment:

VS 2015 Professional
Sencha CMD: latest version
Ext JS: 6.0.1
RAM: 16 GB
System: Win 8.1
Processor: Core i7 4710 MQ
Thanks for your help

Mark.Brocato
7 Mar 2016, 4:11 PM
Yes, there have been some complaints about the performance of intellisense, but we haven't been able to pin down the cause as of yet.

Does it seem to be slow all of the time, or only when completing certain types of code? Any details you could offer would be be greatly appreciated. Also, if you'd be willing to share your code base so I could debug things locally that would be a huge help. PM me if you're willing to do that.

123132
15 Apr 2016, 5:09 AM
Yes, there have been some complaints about the performance of intellisense, but we haven't been able to pin down the cause as of yet.

Does it seem to be slow all of the time, or only when completing certain types of code? Any details you could offer would be be greatly appreciated. Also, if you'd be willing to share your code base so I could debug things locally that would be a huge help. PM me if you're willing to do that.

Hi,

it seems the plugin becomes slowlier while running or coding a long time. When i start VS its fast enaugh to code, but when i step into afternoon and the system is running a long time, its really slow (about 4 chars in a minute). Then VS needs about 700,000 k memory.

Bechard101
7 Jul 2016, 11:32 AM
I had this identical issue. See the solution I found here: https://www.sencha.com/forum/showthread.php?311951-Visual-Studio-2015-Enterprise-Crashing-When-Sencha-Plugin-Enabled-for-Project&p=1139156#post1139156