View Full Version : [FIXED] Unable to run scenario from CLI - err - Could not find module 'process'

5 Feb 2016, 5:57 AM
I have created two test scenarios that are running perfectly from Sencha Studio. But while trying to run them from CLI using CLI package, its throwing an error -Could not find module 'process'.
Error is as shown below:53993

Gary Schlosberg
10 Feb 2016, 11:56 AM
With which version of Windows are you seeing this? What version of Node.js?

10 Feb 2016, 10:57 PM
OS version : Windows 7 Enterprise, Service Pack 1
Node JS version : Installer of Node :: node-v0.10.13-x86.msi

11 Feb 2016, 5:01 AM
This error should be fixed for the GA release.

11 Feb 2016, 7:07 AM
Is there any expected date of next GA release?

11 Feb 2016, 7:25 PM
Shortly :)

16 May 2016, 2:54 AM
Hi,Did this ever get resolved? I have the exact same issue - using the sencha test trial download.Node 0.12.xThanks

Gary Schlosberg
17 May 2016, 9:25 AM
Test 1.0.1 was released on March 1st. Have you tried with that version?

18 May 2016, 2:11 AM
Test 1.0.1 was released on March 1st. Have you tried with that version?

Hi Gary,

Thanks for your response. We are using 1.0.1 - I downloaded the trial version 27 days ago.
Whilst I've had reasonable success constructing and running tests using the test suite interface, I have so far been unable to use the CLI tool.

I have 3 days left to recommend this product to my company (Fixnetix). They are keen to incorporate the test suite but it's essential that we get to this running in a CI environment.

I'm also having issues with the "generic webdriver" approach. Possibly that's due to my lack of experience with Webdriver (and maybe my driver/pool configurations are incorrect). Minimal documentation in this area does not help.

Anyway - bottom line - using 1.0.1 and still the STC doesn't work.


18 May 2016, 9:22 AM
Did you check your Node.js version? STC requires Node.js version 4.2.1 or newer.

18 May 2016, 9:45 AM
OMG I'm such a numpty! Thank you....

Now just to resolve my browser pool issue and we're good to go!
Thanks again

31 May 2016, 4:39 AM
Please let us know how you resolve the browser pool issue, I'm curious cause I doesn't work for me either.. probably didn't configure something properly.

31 May 2016, 10:10 AM
Hi vsciu

You should not see the error "Could not find module 'process'" as long as you use Node.js >= 4.2.1. Is it the same issue you're seeing? Or perhaps related to: https://www.sencha.com/forum/showthread.php?311208-Can-I-run-tests-locally-using-stc-and-selenium-server-or-selenium-grid ?

31 May 2016, 11:24 PM
Hi marcelofarias, I resolved the issue with "Could not find module 'process'." by upgrading to a newer version of node.
However, I'm not sure now what to use as a browser pool for the tests to run locally, not on a browser farm on Saucelabs for example.

1 Jun 2016, 8:47 AM
Using the Selenium server defaults, you should configure your farm in Studio with host as localhost or and port as 4444. Then you can inspect the generated JSON files to check their contents if needed.

Here's an excerpt from a valid workspace.json:

"name": "Local",
"type": "generic",
"host": "",
"port": 4444,
"autoStartTunnel": false,
"sessionLimit": 1,
"pools": [
"name": "local",
"path": "farms/local.json"

The referred local.json file containing the pool definition reads as:

"chunks": 1,
"browserName": "chrome",
"platform": "Mac",
"version": 50
? }