View Full Version : [FIXED] Cannot generate Sencha Touch App

11 Jan 2016, 3:25 PM
I cannot create a Sencha Touch application:

File->New Application:
I tried to point the SDK Path to the Sencha Touch (2.4.2) SDK location, but it says, "Directory is not a valid Framework:"

When I used Sencha Cmd to generate a workspace and then generate a Sencha Touch application, after loading the workspace, I see this error, "Unexpected Token.", and the application just shows up with a 'cancel' icon next to it.

16 Jan 2016, 10:39 AM
Thanks for the report! I have opened a bug in our bug tracker.

20 Jan 2016, 4:24 PM
I just downloaded and installed the Beta version of Sencha Test Studio on Windows and it still has this bug.

22 Jan 2016, 3:53 PM
Thanks for checking back in. Have you tried installing Cmd 6 and opening your existing Sencha Touch application? Or generate the app from the command line and open that? Still a bug but curious if we can work around it until we get a real fix.

22 Jan 2016, 3:59 PM
I have used the command line/studio to generate a new workspace, then add a sencha touch application to it using the command line. In the end, it shows up as an 'undefined undefined' Framework and shows 'Directory is not a valid Framework: <path>\touch' when I hover over it. The Application shows up in the list, but it has a cancel icon and shows 'Bad string' when I hover over it. I also see this message in the Alert's tab: 'Failed to load application "TestApp": Bad string' (There is also no right-click context menu on the application.)

27 Jan 2016, 12:18 PM
Can you post the app.json file for the app?

27 Jan 2016, 1:13 PM
I've attached the two files...

3 Feb 2016, 8:47 PM
One thing we found internally is our JSON parser rejects this:

"ignore": [

Because of the invalid escape character. It was generated by an older version of Cmd but you could probably just remove it. There are some other fixes needed to get Test to work with Sencha Touch I but wanted to mention this one since I saw it in your app.json file.

5 Feb 2016, 4:27 PM
Sounds good, so I just remove the '\' or the whole section?