PDA

View Full Version : [OPEN] Won't even install in RAD 9.1



firefoxSafari
3 Nov 2015, 8:20 AM
We're using IBM Rational Application Developer (RAD) here. I'm on 9.1.1.1 - based on Eclipse 4.2.1, I believe. This is the highest maintenance release of the second to most recent major version of RAD.

Trying to install the plugin results in an unsatisfied dependency.


Cannot complete the install because one or more required items could not be found.
Software being installed: Sencha ExtJS Plugin 6.0.0.188-ea (com.sencha.eclipse.feature.feature.group 6.0.0.188-ea)
Missing requirement: Sencha ExtJS Plugin 6.0.0.188-ea (com.sencha.eclipse.plugin 6.0.0.188-ea) requires 'bundle org.eclipse.ui.ide 3.10.2' but it could not be found
Cannot satisfy dependency:
From: Sencha ExtJS Plugin 6.0.0.188-ea (com.sencha.eclipse.feature.feature.group 6.0.0.188-ea)
To: com.sencha.eclipse.plugin [6.0.0.188-ea]


Very disappointed right now. This is exactly what happened with the last ill-fated Eclipse plugin. It wouldn't install in our current version of RAD at the time and we got 0 benefit from it. Now it looks like history is repeating itself. I've requested to download the most recent version of RAD to see if it works any better, but I'm not holding out much hope...

I did download a fresh copy of Eclipse Mars from eclipse.org and install. It seems ok for an early access tech. The project creation, class creation stuff all seemed to work really well and was intuitive. Code completion on config options was ok. Code completion on method calls was hit-or-miss and had some strange deficiencies. For example, Ext.e... Ctrl+space let me chose Ext.encode, but Ext.Msg... doesn't show up at all in code completion.

Overall, the code navigation and completion doesn't feel well integrated into Eclipse yet. There's no Outline view. Using Shift+F3 to navigate to class declarations is strange. You should be able to Ctrl+click or select a name and do Open Declaration (F3).

It's a good start, though the JetBrains plugin is far superior right now... this might just be a limitation of JetBrains versus Eclipse architecture though.

Please make an attempt to get it working in the major Eclipse variants... if I thought downloading another Eclipse install in addition to what we're using was acceptable, we'd be better off going with WebStorm + RAD...

Chris.OBrien
3 Nov 2015, 10:20 AM
We're using IBM Rational Application Developer (RAD) here. I'm on 9.1.1.1 - based on Eclipse 4.2.1, I believe. This is the highest maintenance release of the second to most recent major version of RAD.
...
I've requested to download the most recent version of RAD to see if it works any better, but I'm not holding out much hope...


Thanks for the input. Right now, our plugin officially supports Eclipse Luna (4.4) and newer. This means it should work on other products based on the Eclipse platform of the same version. Looking at RAD's wiki, it looks like RAD 9.5 is based on 4.4 (https://www.ibm.com/developerworks/community/wikis/home?lang=en#!/wiki/Rational%20Application%20Developer%20Wiki).

We can evaluate extending the supported Eclipse versions, but even jumping back one version (Kepler - 4.3) caused issues with the plugin's dependencies within Eclipse.


Overall, the code navigation and completion doesn't feel well integrated into Eclipse yet. There's no Outline view. Using Shift+F3 to navigate to class declarations is strange. You should be able to Ctrl+click or select a name and do Open Declaration (F3).

We are aware that Shift+F3 and the lack of a Ctrl+click isn't ideal, and we are hoping to improve upon this in the future to use the standard Open Declaration F3 and ctrl+click mechanisms.

I'll create a ticket to evaluate adding an outline view for potential inclusion in a future release, thanks.

We can also investigate the completion issues you mentioned, but can you please provide code examples and details like SDK version, is it a universal app, were you in a classic/modern build, etc.? I was able to complete Ext.Msg but it might be a contextual issue.

firefoxSafari
3 Nov 2015, 11:04 AM
Thanks for the response. I've started the process to download RAD 9.5 and should know more sometime this week. It's good to hear that it's based on 4.4 and so will in theory at least match your minimum version requirements. It's just frustrating being an Eclipse user; it seems we're always caught between vendors. One says their plugin won't work in newer versions, another says their's won't work in older versions. Hopefully everything we need will just work in 9.5.

Regarding the code completion, the sdk was 5.1.2. I just started a new app project, went directly to the onClickButton in MainController.js and tried Ext.Msg. Code completion doesn't find this.

I tried creating another workspace based on 6.0.1. I tried the classic toolkit here and the same thing DOES work... so it looks like it might be something specific to older versions of the sdk.

firefoxSafari
5 Nov 2015, 12:52 PM
Got RAD 9.5 installed here. Plugin still doesn't install. Different dependency error this time.


Cannot complete the install because one or more required items could not be found.
Software being installed: Sencha ExtJS Plugin 6.0.0.188-ea (com.sencha.eclipse.feature.feature.group 6.0.0.188-ea)
Missing requirement: Sencha ExtJS Plugin 6.0.0.188-ea (com.sencha.eclipse.plugin 6.0.0.188-ea) requires 'bundle org.apache.commons.net 3.2.0' but it could not be found
Cannot satisfy dependency:
From: Sencha ExtJS Plugin 6.0.0.188-ea (com.sencha.eclipse.feature.feature.group 6.0.0.188-ea)
To: com.sencha.eclipse.plugin [6.0.0.188-ea]


RAD 9.5 is based on Eclipse 4.4.2.v20150204-1700.

Too bad - looks like once again we will be unable to take advantage of this plugin :(

Please let us know if it ever does work or you have a good workaround...

Chris.OBrien
5 Nov 2015, 1:09 PM
Got RAD 9.5 installed here. Plugin still doesn't install. Different dependency error this time.


Cannot complete the install because one or more required items could not be found.
Software being installed: Sencha ExtJS Plugin 6.0.0.188-ea (com.sencha.eclipse.feature.feature.group 6.0.0.188-ea)
Missing requirement: Sencha ExtJS Plugin 6.0.0.188-ea (com.sencha.eclipse.plugin 6.0.0.188-ea) requires 'bundle org.apache.commons.net 3.2.0' but it could not be found
Cannot satisfy dependency:
From: Sencha ExtJS Plugin 6.0.0.188-ea (com.sencha.eclipse.feature.feature.group 6.0.0.188-ea)
To: com.sencha.eclipse.plugin [6.0.0.188-ea]


RAD 9.5 is based on Eclipse 4.4.2.v20150204-1700.

Too bad - looks like once again we will be unable to take advantage of this plugin :(

Please let us know if it ever does work or you have a good workaround...

That's unfortunate to hear, but I appreciate your follow up.

Looking at our plugin dependencies, I might be able to lower the version number restrictions and make it more flexible. I'll create a ticket in our system for it..

If you're up for some adventure and want to edit the plugin zip, I'll send you a PM to see if we can get this working for you. :)