View Full Version : Works for a new project - nothing for an existing one

3 Nov 2015, 7:27 AM
The plugin seems to work fine for a new project - but I've added the "sencha nature" to an existing project - but I dont seem to get any intellisense.

I still get the ability to add a new sencha item to the solution tree - so it must be enabled.
Dont know if it helps - but if I highlight something and press f12 (which should go to the definition according to the docs) - I get an error :


Any ideas ?

3 Nov 2015, 11:12 AM
Hi zz9pa,Sorry about your issue. So you have an existing Solution with an existing Project that contains an Ext application? Would you mind sharing a bit about your Solution/Project structure in general? What type of Project is the Ext application contained in? Could you also look in the root of your Solution folder (where your .sln file resides) and see if a .sencha-ide-config file exists, and if so what the contents of that file are?Thanks.Chris

3 Nov 2015, 11:42 AM
Its an ExtJS5 "project" - theres the normal app.json stuff in there.
The extjs code resides in a [toplevel]/MyProject/WebSiteSrc directory - which contains the app directory etc.
(There are other helper (c#) projects in the solution)

There is a .sencha-ide directory at the very top level (containing file.json, status.json, usage.json)
But - there is no .sencha-ide-config that I can see.

3 Nov 2015, 5:35 PM
Would you mind viewing the ".sencha-ide-config file" section of the guide here: http://docs.sencha.com/ide_plugins/visual_studio_ide_plugin.html and giving that a shot? Create the .sencha-ide-config file at the same location as your Solution's .sln file and add the Sencha nature to your Project containing your Ext JS source code?

Thanks. Feel free to reach back out with further questions.

4 Nov 2015, 5:31 AM
Hi zz9pa,
the first thing you are able to add Sencha items without Sencha Nature added to your project.
The second thing I was not successfull to reproduce your issue. These are the steps to achieve IntelliSense for previously created Ext JS App:
I created new solution (ComplexSolution) with 3 projects (Console, WindowsForm and WebApplication)
I separately created an Ext JS application with SDK 5.1.1 (SenchaForumTest folder) via Sencha Cmd
Then I add this application under the project WebApplication/FolderExtJS (I copied SenchaForumTest to the folder in File Explorer
In VS I pressed 'Show All Files' in Solution Explorer view and via right-click on that folder I choose 'Include in Project'.
Then I right-click on project and choose 'Add Sencha Nature to Project'. After that few things happens:

In Task manager-Processes: the tern-win64.exe(tern-win32.exe) started
In Visual Studio you can see in Status Bar this message: 'Parsing JS...'.

After that everything is working
Please let me know if you did something different. I attached image for better overview:

I hope it helps :-?

5 Nov 2015, 3:51 AM
When I add the sencha nature to the project - I get the "Parsing JS files for IntelliSense" at the bottom.The "nature" seems to have been added to the project - because the .csproj file changed to include : Adding the .sencha-ide-config seems to have done the trick though - I set that to be top level of the project - should that point to my code (which includes the ext directory), or just a sencha ExtJS framework directory ? Only - setting it to my all of my code - the ide is *really* slow...(my directory though includes the build/production and build/testing etc)

16 Nov 2015, 8:50 AM
it is actually?

3 Dec 2015, 3:50 AM
Hello zz9pa, the new GA release of Visual Studio Plugin is public. Please try it now and let us know if your problem is solved.