PDA

View Full Version : [FIXED] Sencha Inspector executable crashes on startup, can't find user.settings



byronaltice
21 Sep 2015, 1:06 PM
Hello,

I successfully launched Sencha Inspector a while back but today when I tried, I get an error window in windows with the title being "A Javascript error occured in the browser process"

and the message:

"Uncaught Exception:
Error: ENOENT: no such file or directory, open 'H:\AppData\Local\Sencha\Inspector\user.settings'
et Error(native) .........."

I checked that location and user.settings exists on my network drive there. So I tried uninstalling Sencha Inspector and deleting that file, then reinstalling.

It gives this error still, and reinstalling did not create a new user.properties file. So now I just have no user.properties file. I should have backed it up.

How can I get past this?

arthurakay
22 Sep 2015, 6:46 AM
I believe the correct location should be:
- C:\Users\<username>\AppData\Local\Sencha\Inspector\

That assumes you've installed Sencha Inspector on your C: as well... I have heard reports about users trying to install this on a shared network drive and having problems like this. Not really sure why the shared drives are causing problems...

It will create a "user.settings" file with default values on first run (if one doesn't exist) -- so try installing on your local drive and let me know if that fixes things.

byronaltice
22 Sep 2015, 7:30 AM
Yes, I am installing on a local drive (C: ) and for some reason it is looking for user.settings on the network drive (H: ). No idea why this is and there's no registry keys I can find to change what path it is looking for.Even reinstalling now though, it is not creating a user.settings on C: or H:

arthurakay
22 Sep 2015, 7:44 AM
Hmmm... maybe try download the latest BETA version and see if that helps: http://pages.sencha.com/Inspector-Beta.html

If this worked in the past (with the files at that location on H:), then perhaps the folder/file permissions have changed?

Are you running the app "as an Administrator"? Windows loves to force people to do that sometimes, that may also help.

DougCyporyn
23 Sep 2015, 6:59 AM
I am getting the same error as byronaltice. I do have an H:\ drive mapped to my machine, but I am installing on C:\.

I un-installed Inspector, disconnected from H:\, and re-installed. Curiously, I am still getting the following error.

I did install as administrator

Any ideas on how to overcome this issue?

53288

arthurakay
23 Sep 2015, 7:07 AM
Can you copy the contents of your user.settings file into this thread so I can be sure it looks correct?

DougCyporyn
23 Sep 2015, 7:27 AM
I am not finding user settings. I do not have the Inspector directory in C:\Users\\AppData\Local\Sencha. Of course, there is nothing on my H:\ either.

That drive is no longer mapped, so I'm not sure where the installer would have put the user.settings.

The installation.log in the program directory (C:\Program Files (x86)\SenchaInspector\.install4j\installation.log) specifies user.home=C:\Users\zzjfb0...install4j.appDir=C:\Users\zzjfb0\AppData\Local\Temp\

and of course there is a whole bunch of other stuff in that file as well. Not sure if any of it is useful though.

arthurakay
23 Sep 2015, 7:53 AM
That drive is no longer mapped, so I'm not sure where the installer would have put the user.settings.

So the plot thickens here. I wonder if your system (or the way Sencha Inspector reads it, using Node.js) still has the home directory set to the H drive.

Here's what we do to detect the correct location on Windows:


config.settings = path.join(process.env.HOMEDRIVE, process.env.HOMEPATH, 'AppData', 'Local', 'Sencha', 'Inspector');


...so maybe that's the problem. Off the top of my head I don't know how to tell you to change that location, but presumably there is a way for you to do that.

Perhaps I also need to add some logic surrounding this use case, and just forcibly create a backup location if HOME can't be found.

DougCyporyn
23 Sep 2015, 8:07 AM
I think that bit of information helped explain some things. For whatever reason my company likes to set HOMEDRIVE to H:

I'm not entirely sure how to change this temporarily. I may work on it so that I can get Inspector running.

Are you able to use SYSTEMDRIVE instead of HOMEDRIVE in your code?

Here are my defaults:

53290

arthurakay
23 Sep 2015, 8:34 AM
I opened a ticket which I'll address in our GA release (soon) that maps this to somewhere on the local machine, rather than the generic HOMEDRIVE location.

DougCyporyn
23 Sep 2015, 9:12 AM
Here's a workaround for anyone else having this problem:

Create a cmd file with the following:
SET HOMEDRIVE=C:
"C:\Program Files (x86)\SenchaInspector\senchainspector.exe"

Of course, just make sure the path to the exe is correct for your system. Run the cmd file and Inspector should come up.

BTW - found user settings at C:\AppData\Local\Sencha\Inspector after running the cmd file

DougCyporyn
25 Sep 2015, 9:04 AM
I was able to get the app to start up with the above mentioned workaround, however I cannot get any app to connect either with Bookmarklet or with dev build configuration. It just doesn't work.

arthurakay
26 Sep 2015, 3:40 AM
I was able to get the app to start up with the above mentioned workaround, however I cannot get any app to connect either with Bookmarklet or with dev build configuration. It just doesn't work.

Can you start a new thread with more information? That way we have a clean thread on which to discuss that specific problem.