View Full Version : Can't see javascript code in the chrome debugger anymore

22 Jul 2015, 7:55 AM
While working in the chrome dev tools while debugging a fiddle I found that I can no longer see the javascript code I'm debugging.

This happened after I toggled the "Deactivate Breakpoints" button in the tools. When I turned off breakpoints the code ran through without stopping even though I had the debugger keyword in the code.

I toggled the deactivate button back to on and now chrome will stop at the debugger keyword, but the javascript no longer shows.


I've tried the following to fix it with no success:
- Refreshing the tab
- Closing the tab and opening a new one
- Closing the window and opening a new one
- Closing chrome and opening it back up
- Restoring a previous version of my chrome Application Support folder

I've also confirmed that the same fiddle (https://fiddle.sencha.com/#fiddle/qub) will show the code at the breakpoint on a different computer.

Is there a way to fix this? It makes debugging in fiddle a lot harder.

22 Jul 2015, 8:02 AM
This isn't fiddle's issue, this is the browser. Fiddle recreates the HTML that it then dumps into the <iframe> which the browser then evaluates the code.

22 Jul 2015, 8:08 AM
Understood. I didn't think it was a problem with fiddle since it worked on a different computer. I was asking mostly to see if someone has any insight on how to fix the browser problem.

22 Jul 2015, 8:22 AM
Just incase anyone runs into this issue in the future, I resolved it by trashing:

- The chrome app
- The chrome application support folder in my user library: `~/Library/Application Support/Google/Chrome/`
- The google preferences in my user library: `~/Library/Preferences/com.google....`
- Note: you only need to trash the one for chrome

After that I downloaded a new copy of chrome, tested out the fiddle, and the debugger showed up as before.

You may be able to pinpoint where the problem is coming from by trashing the items one at a time starting with the chrome app.