PDA

View Full Version : [FIXED] Deprecation warnings in console



ccg
16 Jul 2015, 9:56 AM
When I connect Inspector to a Sencha Touch 2.3 app, I immediately see 217 of these errors in the console:


"[DEPRECATE][Anonymous] 'ownerCt' is deprecated, please use 'parent' instead"

Each time I select a component from Inspector's tree view to highlight it in the browser, I get one of these warnings in the console:


[Warning] [DEPRECATE][Anonymous] 'el' is deprecated, please use 'element' instead (Console.js, line 35)

I get these warnings in the console for both Chrome and Safari.

arthurakay
17 Jul 2015, 4:15 AM
Thanks for the report! I have opened a bug in our bug tracker.

arthurakay
21 Jul 2015, 6:39 AM
When I connect Inspector to a Sencha Touch 2.3 app, I immediately see 217 of these errors in the console:


"[DEPRECATE][Anonymous] 'ownerCt' is deprecated, please use 'parent' instead"

Each time I select a component from Inspector's tree view to highlight it in the browser, I get one of these warnings in the console:


[Warning] [DEPRECATE][Anonymous] 'el' is deprecated, please use 'element' instead (Console.js, line 35)

I get these warnings in the console for both Chrome and Safari.

Are you looking at an app that is publicly viewable? I'd love to take a look, because using the Touch Kitchen Sink I don't see either of these warnings:
- http://docs.sencha.com/touch/2.3.1/touch-build/examples/kitchensink/index.html

Note: we don't actually consider 2.3 "supported", though it does appear to work quite well.

Even using the 2.4.2 Kitchen Sink, I don't see the warnings:
- http://docs.sencha.com/touch/2.4/2.4.2-apidocs/touch-build/examples/kitchensink/index.html

ccg
21 Jul 2015, 7:42 AM
Are you looking at an app that is publicly viewable? I'd love to take a look, because using the Touch Kitchen Sink I don't see either of these warnings:
- http://docs.sencha.com/touch/2.3.1/touch-build/examples/kitchensink/index.html

Note: we don't actually consider 2.3 "supported", though it does appear to work quite well.


The docs claim Touch 2.1+ is supported. (http://docs.sencha.com/tools/sencha_inspector/installation_setup.html)

I'll try to extract a test case to share (the app in question is not public).

arthurakay
21 Jul 2015, 10:34 AM
LOL yes, in fact we do support 2.1.0+... brain fart.

Yes if you could get me a reproducible test case for those warnings, it would be awesome. Thanks!

arthurakay
29 Jul 2015, 4:23 AM
I have this fixed in the upcoming beta release.