PDA

View Full Version : [FIXED] Component list: minor display issues



ccg
13 Jul 2015, 7:53 AM
The Component list's tree grid does not appear to have a scrollbar, at least on my Mac 10.10 machine. All the other lists (Properties, Stores, etc.) have proper scrollbars.

Also, there are two blank columns in that list that take up screen real estate. Column #2 is totally empty (no header or anything), and column #4 ("Layout") appears to be always empty, at least for the Touch 2.3 app that I'm currently updating.

Screenshot below. Columns: Component ID, blank, XType, Layout. I don't see any way to hide the empty columns.

52840

arthurakay
13 Jul 2015, 9:37 AM
Thanks for the report, Chad.

The second column will display information about data binding, ViewModels and ViewControllers (for Ext 5, 6). Clearly we need a label for the header.

The Layout column... that seems to be a bug. I will log that, thanks for finding it :-) Apparently "component.layout.type" doesn't exist in Touch, d'oh.

Odd that you aren't seeing a vertical scrollbar on that tab though. Is that just because OSX hides the scrollbar until you try scrolling?

ccg
13 Jul 2015, 10:06 AM
Odd that you aren't seeing a vertical scrollbar on that tab though. Is that just because OSX hides the scrollbar until you try scrolling?

No, when you scroll the other lists, the scrollbar appears. The scrollbar never appears in the component tree, even while scrolling with the mouse wheel or whatever. I might be one of the few holdouts who still uses a scrollbar for scrolling, but I miss it when it's not there. :)

arthurakay
17 Jul 2015, 10:54 AM
I have fixed these issues in the upcoming beta release.