View Full Version : Upgrade Ext JS 5.1.1 app to Ext JS 6?

26 May 2015, 12:01 PM
I'm trying out the new Ext JS 6 by upgrading my Ext JS 5.1.1 application. I used the command:

sencha app upgrade <framework>

to install the new framework. It succeeds in 'loading configuration from framework directory' and 'copying framework to ...' but then I get the following:

[ERR] Cannot satisfy requirements for "ext-theme-neptune"!
[ERR] The following versions cannot be satisfied:
[ERR] my-custom-theme: ext-theme-neptune (No matches!)
[ERR] Cannot resolve package requirements

I'm using Sencha CMD and I'm assuming there are some subtle changes I need to make in various places to get this to work correctly? I've had no problems in upgrading my Ext JS 5.x application to different versions of Ext JS 5 so I know things work for that platform. What sort of changes will I need to make so that I can upgrade to Ext JS 6? Alternatively, given a working Ext JS 5.1.1 application (using a custom theme) what are the steps I should take to get it to work with Ext JS 6?



Gary Schlosberg
26 May 2015, 3:43 PM
Do you have your toolkit specified in your app.json?

"toolkit": "classic",

26 May 2015, 5:59 PM
I didn't originally, but after a search on the forum I saw someone mention that so I added it to my app.json. That got me thinking that perhaps there are other little config changes that I might need to make to get things to work. With this change I still get the same error. Is there a document somewhere which would outline the steps needed to get an Ext JS 5.x application running under Ext JS 6? Or, is it just too soon to try such a thing?

27 May 2015, 7:45 AM
It turns out that when I added the "toolkit":"classic" to my app.json, I did it in the wrong directory (I copied my app to a new location for Ext JS 6 work). After fixing the right app.json, and downloading the latest Ext JS 6 Beta (framework and CMD), the upgrade process completes successfully. Don't know if the app will run, but at least the upgrade finished.


Gary Schlosberg
8 Jun 2015, 3:54 PM
Thanks for the update -- glad to hear that you got it sorted. Hope the app is running as well.