View Full Version : Disabling mouse over effect on EXT JS Grid header

rahul patil
3 Apr 2015, 3:32 AM

I am trying to disable the mouse over effect on EXT JS grid header.
I tried with following but it did not work
viewConfig: {
trackMouserOver : false
I am using extjs 4.1.3.
Here is my grid header:

Any help would be appreciated.

Gary Schlosberg
3 Apr 2015, 3:31 PM
Here's a thread describing a method of attaching a listener to the grid headers.

3 Apr 2015, 7:38 PM
Something like this?


You could specify the hoverCls directly on each column but using defaults seems easier.

That CSS class also shows the menu trigger. If you want to maintain that part of the functionality you'll need to use an alternative CSS class (rather than just removing it) that keeps the display: block on the trigger.

rahul patil
4 Apr 2015, 12:27 AM
Thanks Skirtle.
setting hoverCls in defaults worked. Thanks a lot.

6 Dec 2016, 9:45 PM
It's not working