View Full Version : HtmlEditor not showing value of "textarea" in Internet Explorer

16 Jan 2015, 4:24 AM
Hi all,

I have a HtmlEditor that must be updated with values retrieved from the server.

I get the component by id and call "myComponent.setValue("someValue").

This works fine in Chrome and Firefox.

In Internet Explorer, it does NOT. The htmlEditor is left blank.

However if I call "myComponent.getValue()", I can see the value has been set correctly.
I can also view the page source and see that the "textarea" contains the value I set, but the iFrame beneath does not.

I have tried calling "myComponent.syncValues()" to force the textarea value to be copied across to the iFrame, but it didn't work.

Is there anything I am missing?

Sincere apologies for not posting my code, I do not think I am allowed post company code on the net. I really appreciate any assistance you could render. Thank you.

16 Jan 2015, 4:39 AM
I should also mention, this is all versions of IE (8,9,10) and that I have searched the forums for similar problems already but found no solution :)

16 Jan 2015, 4:59 AM
Further info: I put in a listener on my htmlEditor, sending out an Alert if the "push" event was fired, which it is when the textarea value is copied to the iFrame.This event IS fired in Chrome/FF, but is NOT called in IE. So, it would seem ExtJs is not attempting to push the value, anyway to force it?

Gary Schlosberg
16 Jan 2015, 5:33 AM
Sounds like it could be a bug. Do you have a test case we can use to see the behavior?

16 Jan 2015, 7:40 AM
Thank you very much for the quick reply.Unfortunately it's a very complex screen and I'm not sure how I'd extract and anonymise the relevant parts. We absolutely cannot post any of our actual code either so it's difficult for you guys to help me, I know.I've since tried manually calling the "syncValue" and "pushValue" methods on the HtmlEditor. Still no joy. I can see the value in the hidden text area, it's just not being transferred across to the iField no matter what I do...I think I will have to change to a text area if I can't get this htmleditor working.

25 May 2016, 1:49 PM
I'm facing this issue as well, any news on this? Thanks!

25 May 2016, 7:37 PM
I ran closure-linter and it reported a missing semi-colon at the end of a function assignment to a variable, adding that semi-colon solved the issue.

Gary Schlosberg
26 May 2016, 2:43 PM
Glad to hear it, and thanks for sharing your solution with the community.