View Full Version : Problem setting up Ext.azure

14 Mar 2014, 4:40 AM
I'm trying to integrate the Windows Azure extension into a project, but I'm getting errors from sencha cmd when I try to do the app refresh. Also, I do not see any of the Azure controllers under extensions in Architect.

I installed the touch-azure package with: sencha package get touch-azure

This completes without error. In my app config, I have the following:

Ext.Loader.setConfig({ paths: {
Ext: '.',
'Ext.azure': 'packages/touch-azure/src/'


requires: [
name: 'aztest'

But when I do an app refresh, I get.

[ERR] C2008: Requirement had no matching files (Ext.azure.Azure) -- C:\xampp\htdocs\aztest\aztest\app.js:29:32[ERR]
[ERR] com.sencha.exceptions.ExBuild: Failed to find any files for C:\xampp\htdocs\aztest\aztest\app.js::ClassRequire::Ext.azure.Azure
[ERR] Total time: 7 seconds
[ERR] The following error occurred while executing this line:
C:\Users\jcole_000\bin\Sencha\Cmd\\plugins\touch\2.3\plugin.xml:326: The following error occurred while executing this line:
C:\xampp\htdocs\aztest\aztest\.sencha\app\build-impl.xml:367: The following error occurred while executing this line:
C:\xampp\htdocs\aztest\aztest\.sencha\app\js-impl.xml:11: com.sencha.exceptions.ExBuild: Failed to find any files for C:\xampp\htdocs\aztest\aztest\app.js::ClassRequire::Ext.azure.Azure

I'm using Architect version

18 Mar 2014, 8:37 AM
You mentioned that you installed the package via Cmd. There was a bug in Cmd when we first released this package where it failed to include the Architect bindings... so while that bug has since been fixed, I don't know if our Cmd CDN has updated the package yet or not.

So the first thing I'm going to ask you to do is to download the ZIP directly from Sencha Market:
- https://market.sencha.com/extensions/sencha-touch-extensions-for-windows-azure

Next, you'll need to follow the user guide we have for installing the package into Architect. Sadly Cmd doesn't automatically do this for you:
- http://docs.sencha.com/touch-azure/1.0.0/#!/guide/architect

The most important part of that guide is that top, where we instruct you to copy the package contents to the Architect extensions folder. Then you should be able to restart Architect and see the UX classes in your toolbox.

Give that a shot and let me know if you still have errors.

19 Mar 2014, 12:41 PM
I copied the contents of the zip to the folder specified, and the components still do not show up in Architect. 48362

19 Mar 2014, 12:53 PM
What version of Windows are you running? And what's the fully qualified file path you're sticking this in?

19 Mar 2014, 4:31 PM
Windows 8.1

The path is: C:\Users\jcole_000\Documents\Architect\Extensions\

In Architect under preferences, file, the extensions path is set to:


I have tried this on 2 different computers with the same result.

19 Mar 2014, 4:33 PM
I'll look into it. I know Windows machines sometimes expect "Documents" to be in different places, which is why my tutorial was for Mac as it was consistent. I'll try to get back to you tomorrow.

20 Mar 2014, 7:49 AM
I'm still waiting for the Architect team to answer some questions for me, but just to troubleshoot... do you actually see files in the /architect/ folder of the touch-azure package? There should be three JS files.

20 Mar 2014, 8:00 AM
Yes, the three files are there.

20 Mar 2014, 8:42 AM
edit: apologies, I wasn't familiar with this package at the time - I need to revisit my reply here!

20 Mar 2014, 9:10 AM
Steve pointed me in the right direction... somehow our package.json got corrupted.

If you open package.json, you'll find:

"type": "code”,

...where the final double-quote got bungled into a smart-quote. Can you manually fix that? That should fix the problems for you.

I need to run a fresh build and pop the fix onto Sencha Market, but that may take me some time.

20 Mar 2014, 9:26 AM
That makes sense. I made the change, but it's still not working. I do however note a popup now when opening a project in Architect: "Unable to import package touch-azure."

20 Mar 2014, 10:05 AM
We're getting somewhere! Is that the only error you see?

FYI I'm trying to track down the Sencha Market login to update the ZIP. It's too big to attach here in the forums.

20 Mar 2014, 12:18 PM
That solved it (I looked at the log messages and files were missing). It was a combination of the problem with the package and it was missing files from the src folder, which was something I did experimenting with different possibilities. So, your fix worked. Thank you very much for looking into this and your help.

20 Mar 2014, 12:19 PM
Great! Sorry again for the hassle, I don't know how that magic quote mark got in there... :-?

21 Mar 2014, 11:40 AM
FYI, I did manage to update Sencha Market's ZIP file.

The problem *should* now be fixed! ~o)

6 Apr 2014, 10:51 AM
I don't mean to hijack this thread, but I'm having a similar problem with architect 3.

I can't seem to find the equiv location on a windows 8.1 machine to install the architect extension files.

I don't see anything architect related under C:\Users\peterkellner\Documents or C:\Users\Default\Documents

CMD did install touch-azure here: C:\Users\peterkellner\bin\Sencha\Cmd\\extensions

When I create a new architect project (ST2.3) my extensions are empty.

I did find the three files in this directory: C:\Users\peterkellner\bin\Sencha\Cmd\\extensions\touch-azure\architect (controllerdefinitions,proxydefinition,storedefinition)

6 Apr 2014, 2:35 PM
You should be able to go to the Architect preferences, and under the "File" section, see the settings for each path under "Asset Storage" - I'm surprised it's not C:\users\peterkellner\Documents though - that's strange! I'd appreciate if you could report back and tell us where it did go - do your applications get installed under a different username (e.g. admin) or something?

6 Apr 2014, 2:40 PM
Ah, that is set to //psf/Home/Documents/Architect/Extensions/ .I'm running parallels on a mac and have probably moved the VM. I never put anythng on that shared drive on purpose. How can I change those to a local drive (C:\...) and get the azure files to go there?Right now, I have no directory \\psf\Home\Documents\Architect

6 Apr 2014, 2:42 PM
you ought to be able to just edit the setting right there and save it, should be good to go! I'd suggest C:\users\pkellner\Documents\Architect\Extensions (for extensions) and similar structure for your others - but you could also certainly store them elsewhere, e.g. C:\Architect\Extensions or wherever you please!

6 Apr 2014, 2:49 PM
OK, here is what I've done now.I changed the extensions in preferences to C:\Users\peterkellner\Documents\Architect\Extensions (not the components ore templates defaults).copied the 3 azure extension files to that directorysaved and exited architectran architectcreated new ST2.3 projectsaved and build run (log attached)My extensions in the list of aailable resources is still Extensions(0)
3:46:20 PM"C:/Users/peterkellner/bin/Sencha/Cmd/" generate app --refresh=false MyApp1 "C:/temp/WebAzureMobile/WebAzureMobile/MyApp1/"C:\Program Files (x86)\SenchaArchitect3>cd /D "C:\Users\peterkellner\AppData\Local\Sencha\Sencha Architect 3.0\assets\touch23\\commercial" C:\Users\peterkellner\AppData\Local\Sencha\Sencha Architect 3.0\assets\touch23\\commercial>"C:/Users/peterkellner/bin/Sencha/Cmd/" generate app --refresh=false MyApp1 "C:/temp/WebAzureMobile/WebAzureMobile/MyApp1/" Sencha Cmd v4.0.2.67[INF] [INF] init-plugin:[INF] [INF] -before-generate-workspace:[INF] [INF] cmd-root-plugin.init-properties:[INF] [INF] init-properties:[INF] [INF] init-sencha-command:[INF] [INF] init:[INF] [INF] generate-workspace-impl:[INF] [echo] generating into C:\temp\WebAzureMobile\WebAzureMobile\MyApp1 from C:\Users\peterkellner\bin\Sencha\Cmd\[INF] [mkdir] Created dir: C:\temp\WebAzureMobile\WebAzureMobile\MyApp1\packages[INF] [INF] cmd-root-plugin.copy-framework-to-workspace-impl:[INF] [propertyfile] Updating property file: C:\temp\WebAzureMobile\WebAzureMobile\MyApp1\.sencha\workspace\sencha.cfg[INF] [INF] copy-framework-to-workspace-impl:[INF] [copy] Copying 2330 files to C:\temp\WebAzureMobile\WebAzureMobile\MyApp1\touch[INF] [copy] Copied 334 empty directories to 1 empty directory under C:\temp\WebAzureMobile\WebAzureMobile\MyApp1\touch[INF] [copy] Copying 1 file to C:\temp\WebAzureMobile\WebAzureMobile\MyApp1\touch[INF] [copy] Copying 1 file to C:\temp\WebAzureMobile\WebAzureMobile\MyApp1\touch[INF] [propertyfile] Updating property file: C:\temp\WebAzureMobile\WebAzureMobile\MyApp1\.sencha\workspace\sencha.cfg[INF] [INF] copy-framework-to-workspace:[INF] [INF] generate-workspace:[INF] [INF] -after-generate-workspace:[INF] [INF] init-plugin:[INF] [INF] cmd-root-plugin.init-properties:[INF] [INF] init-properties:[INF] [INF] init-sencha-command:[INF] [INF] init:[INF] [INF] before-upgrade:[INF] [INF] generate-app-impl:[INF] [INF] generate-starter-app:[INF] [mkdir] Created dir: C:\temp\WebAzureMobile\WebAzureMobile\MyApp1\app\profile[INF] [INF] copy-sdk:[INF] [copy] Copying 1 file to C:\temp\WebAzureMobile\WebAzureMobile\MyApp1\resources\css[INF] [copy] Copying 14 files to C:\temp\WebAzureMobile\WebAzureMobile\MyApp1\resources\sass\stylesheets[INF] [INF] after-upgrade:[INF] [INF] generate-app:[INF] [INF] -after-generate-app:[INF] [x-property-file] Updating property file: C:\temp\WebAzureMobile\WebAzureMobile\MyApp1\.sencha\app\sencha.cfg3:46:32 PM"C:/Users/peterkellner/bin/Sencha/Cmd/" app refreshC:\Program Files (x86)\SenchaArchitect3>cd /D "C:\temp\WebAzureMobile\WebAzureMobile\MyApp1" C:\temp\WebAzureMobile\WebAzureMobile\MyApp1>"C:/Users/peterkellner/bin/Sencha/Cmd/" app refresh Sencha Cmd v4.0.2.67[INF] [INF] init-plugin:[INF] [INF] cmd-root-plugin.init-properties:[INF] [INF] init-properties:[INF] [INF] init-sencha-command:[INF] [INF] init:[INF] [INF] app-refresh:[INF] [echo] Refreshing app at C:\temp\WebAzureMobile\WebAzureMobile\MyApp1[INF] [INF] app-refresh-impl:[INF] [INF] -before-init-local:[INF] [INF] -init-local:[INF] [INF] -after-init-local:[INF] [INF] init-local:[INF] [INF] find-cmd-in-path:[INF] [INF] find-cmd-in-environment:[INF] [INF] find-cmd-in-shell:[INF] [INF] init-cmd:[INF] [echo] Using Sencha Cmd from C:\Users\peterkellner\bin\Sencha\Cmd\ for C:\temp\WebAzureMobile\WebAzureMobile\MyApp1\build.xml[INF] [INF] -before-init:[INF] [INF] -init:[INF] Initializing Sencha Cmd ant environment[INF] Adding antlib taskdef for com/sencha/command/compass/ant/antlib.xml[INF] [INF] -after-init:[INF] [INF] -before-init-defaults:[INF] [INF] -init-defaults:[INF] [INF] -after-init-defaults:[INF] [INF] -init-compiler:[INF] [INF] init:[INF] [INF] refresh:[INF] [INF] -before-refresh:[INF] [INF] -init:[INF] [INF] -init-compiler:[INF] [INF] -detect-app-build-properties:[INF] Loading app json manifest...[INF] Loading classpath entry C:\temp\WebAzureMobile\WebAzureMobile\MyApp1\touch\src[INF] Loading classpath entry C:\temp\WebAzureMobile\WebAzureMobile\MyApp1\app.js[INF] Loading classpath entry C:\temp\WebAzureMobile\WebAzureMobile\MyApp1\app[INF] Loading classpath entry C:\temp\WebAzureMobile\WebAzureMobile\MyApp1\build\temp\production\MyApp1\sencha-compiler\app[INF] Loading classpath entry C:\temp\WebAzureMobile\WebAzureMobile\MyApp1\build\temp\production\MyApp1\sencha-compiler\app[INF] Concatenating output to file C:\temp\WebAzureMobile\WebAzureMobile\MyApp1/build/temp/production/MyApp1/sencha-compiler/cmd-packages.js[INF] Adding external reference : @full-page => @overrides[INF] Loading classpath entry C:\temp\WebAzureMobile\WebAzureMobile\MyApp1\build\temp\production\MyApp1\sencha-compiler\cmd-packages.js[INF] Adding external reference : Ext.util.Observable => C:\temp\WebAzureMobile\WebAzureMobile\MyApp1/build/temp/production/MyApp1/sencha-compiler/cmd-packages.js[INF] [INF] -refresh-app:[INF] Appending concatenated output to file C:\temp\WebAzureMobile\WebAzureMobile\MyApp1/bootstrap.js[INF] Appending concatenated output to file C:\temp\WebAzureMobile\WebAzureMobile\MyApp1/bootstrap.js[INF] Appending concatenated output to file C:\temp\WebAzureMobile\WebAzureMobile\MyApp1/bootstrap.js[INF] Appending concatenated output to file C:\temp\WebAzureMobile\WebAzureMobile\MyApp1/bootstrap.js[INF] Appending concatenated output to file C:\temp\WebAzureMobile\WebAzureMobile\MyApp1/bootstrap.js[INF] Appending content to C:\temp\WebAzureMobile\WebAzureMobile\MyApp1/bootstrap.json[INF] [INF] -refresh:[INF] [INF] -after-refresh:

6 Apr 2014, 5:20 PM
When you mention you copied the 3 Azure extension files, I'm assuming you're either looking at a package that's not for architect or perhaps they're just Ext.ux.* classes - that's not going to work in Architect.

If you already know this, my apologies - but there has been some confusion in the past.

Architect extensions aren't the same thing as packages. You need to install them into Architect, and they'll be downloadable in the form of a *.aux file.

30 Aug 2015, 8:55 AM
HI some have solution to integrate Azure in SA win8.1 ?

I did the is in the documentation and don't show up in SA's toolbox